helpf.pro
Регистрация
 0 
Распечатать

1С 8.3 : Вывод в поле Наименование справочника Штатное список значений из справочника Подразделения?

Есть два справочника Штатное и Подразделения. В справочнике Штатное есть автоматически генерируемое поле Наименование. Как программно сделать так чтобы в поле Наименование справочника Штатное выводились списком значений из поля Наименование справочника Подразделения? Я только начал изучать программирование в 1С. Вариант с добавлением в код модуля списка выбора я уже реализовал. Но сами понимаете что это не то. Посмотрите код. Может у кого то решение есть лучше.

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

Элементы.Наименование.РежимВыбораИзСписка = Истина;

Элементы.Наименование.СписокВыбора.Добавить("Администрация");

Элементы.Наименование.СписокВыбора.Добавить("Бухгалтерия");

Элементы.Наименование.СписокВыбора.Добавить("Отдел ИТ");

КонецПроцедуры

&НаКлиенте

Процедура ТЧШтатноеЕдиницыПриИзменении(Элемент)

РассчитатьСуммуТЧШтатное();

КонецПроцедуры

&НаКлиенте

Процедура ТЧШтатноеОкладПриИзменении(Элемент)

РассчитатьСуммуТЧШтатное();

КонецПроцедуры

&НаКлиенте

Процедура ТЧШтатноеСуммаПриИзменении(Элемент)

Стр = Элементы.ТЧШтатное.ТекущиеДанные;

Если Стр.Единицы=0 И Стр.Оклад=0 Тогда

ИначеЕсли Стр.Единицы=0 Тогда

Стр.Единицы=Стр.Сумма / Стр.Оклад;

ИначеЕсли Стр.Оклад=0 Тогда

Стр.Оклад=Стр.Сумма / Стр.Единицы;

Иначе

Стр.Оклад=Стр.Сумма / Стр.Единицы;

КонецЕсли;

КонецПроцедуры

&НаКлиенте

Процедура РассчитатьСуммуТЧШтатное()

Стр = Элементы.ТЧШтатное.ТекущиеДанные;

Стр.Сумма = Стр.Единицы * Стр.Оклад;

КонецПроцедуры

&НаКлиенте

Процедура ЕдиницыИтогПриИзменении(Элемент)

Стр = Элементы.Штатное.ТекущиеДанные;

Стр.ЕдиницыИтог = Стр.Единицы + 1;

КонецПроцедуры

&НаКлиенте

Процедура СуммаИтогПриИзменении(Элемент)

Стр = Элементы.Штатное.ТекущиеДанные;

Стр.СуммаИтог = Стр.Сумма + 1;

КонецПроцедуры

&НаКлиенте

Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)

Объект.ЕдиницыИтог = Объект.ТЧШтатное.Итог("Единицы");

Объект.СуммаИтог = Объект.ТЧШтатное.Итог("Сумма");

КонецПроцедуры

Разместил:   Версии: | 8.3 |  Дата:   Прочитано: 10216
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 8
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код заполнения ТЧ НаСервере П
10060 (0x0000274C): Попытка установить соединение была безуспешной 24
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через терминал, а еще у нее свой ноутбук и
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 51
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно использовать, когда требуется получ
1C: Enterprise Development Tools 52
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 1
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже веб-узла в э
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.