helpf.pro
Регистрация

v8: Вывод области в конце ТабДокумента

Sustav
22.03.2013 02:15Прочитано: 6093
Доброго времени. Такой вопрос:
Значит вывожу в табличный документ Шапку, Строки, а для того чтобы вывести подвал в конце страницы делаю так:
ТабДок = Новый ТабличныйДокумент;
ТабДок.РазмерСтраницы = "A4";
Макет = ПолучитьМакет("Макет2");

ОбластьШапки = Макет.ПолучитьОбласть("Шапка");
.......
ТабДок.Вывести(ОбластьШапки);

ОбластьПараметров = Макет.ПолучитьОбласть(ОбластьПараметров);
ТабДок.Вывести(ОбластьПараметров);


КонецЦикла;
ОбластьИтог = Макет.ПолучитьОбласть("Итог");
ОбластьИтог.Области.Итог.ВысотаСтроки = 1;



ОбластьПодписи = Макет.ПолучитьОбласть("Подписи");


Т = Новый Массив;
Т.Добавить(ОбластьШапки);
Т.Добавить(ОбластьПараметров);
Т.Добавить(ОбластьИтог);
Т.Добавить(ОбластьПодписи);

Пока ТабДок.ПроверитьВывод(Т) Цикл
ОбластьИтог.Области.Итог.ВысотаСтроки = ОбластьИтог.Области.Итог.ВысотаСтроки + 1;
Т.Установить(2,ОбластьИтог);
КонецЦикла;
//ТабДок.Вывести(ОбластьПодписи);
//ТабДок.Области.Шапка.ВысотаСтроки = 100;
ОбластьИтог.Области.Итог.ВысотаСтроки = ОбластьИтог.Области.Итог.ВысотаСтроки - 1;
ТабДок.Вывести(ОбластьИтог);
ТабДок.Вывести(ОбластьПодписи);
//ТабДок.Области.Шапка.АвтоВысотаСтроки = Ложь;

//ТабДок.АвтоМасштаб = Истина;
ТабДок.ПолеСлева = 15;
ТабДок.Показать();
КонецЕсли;
КонецПроцедуры

Дело в том что все равно ВысотаСтроки достигает 50 и больше не растет и подвал выводится не в конце страницы!
Подскажите в чем может быть дело?
Спасибо!
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
25.03.2013 00:24Ответ № 1
а зачем именно нужно увеличивать высоту? просто выводить новые строки не подходит?
DJ_Serega
25.03.2013 12:05Ответ № 2
(0) Sustav, возможно и не получится. В экселе есть ограничение.
Подсказка: Для редактирования своего ответа щелкните по значку (справа)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.