helpf.pro
Регистрация

Как на календарь назначить задачи

SOBOLEV
03.09.2010 14:44Прочитано: 2604
Здравствуйте пожалуйста помогите с вопросом желательно бы пример кода +) )
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
03.09.2010 16:02Ответ № 1
Что значит на календарь добавить задачи? как в аутлуке что ли?
SOBOLEV
03.09.2010 16:59Ответ № 2
ну вот смотри допустим я хочу чтобы в определённую дату формировался определённый отчёт самостоятельно. это возможно?
E_Migachev
06.09.2010 13:42Ответ № 3
Да, для этого есть Регламентные задания!
SOBOLEV
07.09.2010 10:49Ответ № 4
а можно по подробней!
E_Migachev
07.09.2010 12:31Ответ № 5
(4) SOBOLEV, подробнее о регламентных заданиях здесь
Создаешь задание, в коде обработки пишешь код формирования отчета, в котором указываешь любую дату, куда сохранить, что вывести в отчет...
SOBOLEV
08.09.2010 16:57Ответ № 6
Процедура ОбработкаЗаданий()
ВыполнитьОбработкуЗаданий();
КонецПроцедуры

ПодключитьОбработчикОжидания("ОбработкаЗаданий", 3);
у меня файловый вариант работы но у меня она не работает я прав её же в модуль вставлять?
E_Migachev
08.09.2010 17:10Ответ № 7
(6) используй для запуска обработку из 5 ответа
E_Migachev
08.09.2010 17:29Ответ № 8
для ручного запуска, для отладки:
Вотссылка на обработку
Запускаешь ее, указываешь какое регламентное задание выполнить и жмешь выполнить

Для автоматического запуска в файловом варианте:
ПодключитьОбработчикОжидания("ОбработкаЗаданий", 3);
Добавляешь это в Модуле Приложений
SOBOLEV
09.09.2010 09:20Ответ № 9
ПодключитьОбработчикОжидания("ОбработкаЗаданий", 3);
спасибо за консоли это понятно вот ещё вопрос в общем модуле я создаю задание выпрыгивает модуль я туда вставляю Обработчик ожидания правильно? если да то у меня он почему то не работает выдаёт ошибку при сохранении {ОбщийМодуль.РегламентныеПроцедуры(3,15)}: Обнаружено логическое завершение исходного текста модуля
КонецПроцедуры<<?>>
Из а этого нечего не работает как я понял.
SOBOLEV
09.09.2010 09:22Ответ № 10
просто обычно все работают в созданной конфигурации а я создаю свою может быть с этим связано?? *17
SOBOLEV
09.09.2010 09:34Ответ № 11
и ещё когда запускаешь консоль заданий выпрыгивает
{Форма.ФормаКонсоли(104)}: Ошибка при вызове метода контекста (ПолучитьФоновыеЗадания): Менеджер заданий не активен.
Фоновые = ФоновыеЗадания.ПолучитьФоновыеЗадания(Отбор);
по причине:
Менеджер заданий не активен.
что это? )
E_Migachev
09.09.2010 10:11Ответ № 12
Вообщем так: про Менеджер заданий не активен
А если в каратце, то нужно сделать так:
1. Создать пользователя Регламент
2. ТОЛЬКО для этого пользователя периодически вызывать функцию глобального контекста ВыполнитьОбработкуЗаданий
Код 1C v 8.х
  Процедура ОбработкаЗаданий()
ВыполнитьОбработкуЗаданий();
КонецПроцедуры
ПодключитьОбработчикОжидания("ОбработкаЗаданий", 3);

3. Когда хочешь чтобы Регламентные задания выполнялись, запускаешь базу под этим пользователем(клиентский процесс) и пусть она висит запущенная! И Не рекомендуется это клиентский процесс, выполняющий обработку фоновых заданий, использовать для других функций.
SOBOLEV
10.09.2010 11:21Ответ № 13
где в пользователе можно поставить второй пункт+) 2. ТОЛЬКО для этого пользователя периодически вызывать функцию глобального контекста и какие прова ему следует задать администратора??
E_Migachev
10.09.2010 11:35Ответ № 14
Права полные задавай,
а про выполнение сделай так:
1. Созай новую обработку, в модуле добавь процедуру:
Код 1C v 8.х
   Процедура ОбработкаЗаданий()
ВыполнитьОбработкуЗаданий();
КонецПроцедуры

А в процедуре кнопки Выполнить
Код 1C v 8.х
 ПодключитьОбработчикОжидания("ОбработкаЗаданий", 3);   

2. Запускай базу от этого пользователя
3. открывай созданную обработку и жми Выполнить
4. Проверяй в Журнале Регистарции, выполняются ли регламентные задания?!
SOBOLEV
14.09.2010 13:14Ответ № 15
как сделать что бы 2. ТОЛЬКО для этого пользователя периодически вызывать функцию глобального контекста ВыполнитьОбработкуЗаданий ?
и как Проверяй в Журнале Регистарции, выполняются ли регламентные задания ? там же толька показан сеанс?
SOBOLEV
14.09.2010 13:18Ответ № 16
е иещё все регламентные задания навешать на пользователя Регламент и когда я буду под ним заходить всё будет автоматически выполнятся
SOBOLEV
14.09.2010 13:18Ответ № 17
е иещё все регламентные задания навешать на пользователя Регламент и когда я буду под ним заходить всё будет автоматически выполнятся
E_Migachev
14.09.2010 16:05Ответ № 18
Продолжение в использование Регламентированных заданий
Подсказка: Для редактирования своего ответа щелкните по значку (справа)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.