helpf.pro
Регистрация

v8: 1с в Ворд

Bell
16.04.2013 14:08Прочитано: 1090
Здравствуйте
Есть документ 1с передаю данные из его в ТЧ документа ворд. Данные передаются

Код 1C v 8.х
 НачалоСоСтроки = 2;
НомерСтроки = 0;
Для каждого СтрокаТЧ Из СсылкаНаОбъект.Сотрудники Цикл

Ворд.Tables(1).Rows.Add();// ?????
НачалоСоСтроки = НачалоСоСтроки + 1;
НомерСтроки = НомерСтроки + 1;

Док.Tables(1).Cell(НачалоСоСтроки, 1).Range.Text = СтрокаТЧ.Сотрудники.Наименование;
Док.Tables(1).Cell(НачалоСоСтроки, 2).Range.Text = СтрокаТЧ.Подразделение.Наименование;
Док.Tables(1).Cell(НачалоСоСтроки, 3).Range.Text = СтрокаТЧ.Подразделение.Наименование;
Док.Tables(1).Cell(НачалоСоСтроки, 4).Range.Text = СтрокаТЧ.ДатаПриема;
Док.Tables(1).Cell(НачалоСоСтроки, 5).Range.Text = НомерСтроки;

//Сообщить(СтрокаТЧ.Сотрудники);

КонецЦикла;


Вопрос №1
В ТЧ ворд передается одна лишняя строка (идентификаторы колонок).Как убрать эту строку?
Ворос №2
Ворд.Tables(1).Rows.Add();
Хотелось бы задавать свое имя ТЧ в ворде.(для понятливости)У меня их будет несколько
Yandex
Возможно, вас также заинтересует
Реклама на портале
Bell
16.04.2013 14:10Ответ № 1
title
DJ_Serega
16.04.2013 16:11Ответ № 2
А нужно только табличную часть сохранить?

Есть такая возможность.
Код 1C v 8.х
 
ТабДок = Новый ТабличныйДокумент;
ТабДок.Записать(ИмяФайла + ".docx", ТипФайлаТабличногоДокумента.DOCX);
Mokey
16.04.2013 16:14Ответ № 3
Код 1C v 8.х
 
Для Каждого СтрокаТовара Из ОбъектДокумент.СвернутыйТовар Цикл
НомерВыводимойСтроки = ОбъектДокумент.СвернутыйТовар.Индекс(СтрокаТовара)+2;
//Добавим строку в таблицу
СОМОбъектWord.Tables(1).Rows.Add();
СОМОбъектWord.Tables(1).Cell(НомерВыводимойСтроки,1).Range.Text = Текст1;
СОМОбъектWord.Tables(1).Cell(НомерВыводимойСтроки,2).Range.Text = Текст2;
СОМОбъектWord.Tables(1).Cell(НомерВыводимойСтроки,3).Range.Text = Текст3;
СОМОбъектWord.Tables(1).Cell(НомерВыводимойСтроки,4).Range.Text = Текст4;
СОМОбъектWord.Tables(1).Cell(НомерВыводимойСтроки,5).Range.Text = Текст5;
КонецЦикла;

я так сделал, но таблица у меня одна, поэтому я не заморачивался с её именем
Mokey
16.04.2013 16:17Ответ № 4
(2) DJ_Serega, не работает ничего, кроме как в эксель сохранить, при таком варианте сохранения, только интерактивно.
Изменено 16.04.13 16:17:48
Ermak
16.04.2013 16:51Ответ № 5
Интересная тема, буду следить )
Bell
16.04.2013 17:00Ответ № 6
Переделал вот так, но все равно есть одна пустая строка в конце ТЧ.

НомерСтроки = 0;
Для Каждого СтрокаТЧ Из СсылкаНаОбъект.Сотрудники Цикл
НачалоСоСтроки = СсылкаНаОбъект.Сотрудники.Индекс(СтрокаТЧ)+2;
//Добавим строку в таблицу
Док.Tables(1).Rows.Add();
НомерСтроки = НомерСтроки + 1;

Док.Tables(1).Cell(НачалоСоСтроки,1).Range.Text = СтрокаТЧ.Сотрудники.Наименование;
Док.Tables(1).Cell(НачалоСоСтроки,2).Range.Text = СтрокаТЧ.Подразделение.Наименование;
Док.Tables(1).Cell(НачалоСоСтроки,3).Range.Text = СтрокаТЧ.Отдел.Наименование;
Док.Tables(1).Cell(НачалоСоСтроки,4).Range.Text = СтрокаТЧ.ДатаПриема;
Док.Tables(1).Cell(НачалоСоСтроки,5).Range.Text = НомерСтроки;
КонецЦикла;
Изменено 16.04.13 17:02:38
Mokey
16.04.2013 17:04Ответ № 7
(6) Bell, а в ТЧ нет пустой строки в конце??
ей просто неоткуда взяться, кроме как из самой ТЧ
Изменено 16.04.13 17:05:54
Bell
16.04.2013 17:26Ответ № 8
Код 1C v 8.х
    
Bell
16.04.2013 17:28Ответ № 9
Вот фото
title
Изменено 16.04.13 17:30:37
Mokey
18.04.2013 11:11Ответ № 10
(9) Bell, так а строк-то сколько в СсылкаНаОбъект.Сотрудники?
Bell
23.04.2013 12:44Ответ № 11
Шесть, а последнюю (наверное авто) . Как избавиться от ее.
Mokey
24.04.2013 14:07Ответ № 12
(11) Bell, что за авто? не знаю таких
Bell
24.04.2013 18:14Ответ № 13
Вопрос закрыт!
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.