helpf.pro
Регистрация

v7: Выгрузка регистра

rt55377
18.04.2013 17:58Прочитано: 1046
Здравия желаю!
Задача: выгрузка данных регистра остатков в TXT.
Суть проблемы: не получается выгрузить значение одного из измерений регистра... тип значения - справочник(подчинённый), данные в выгрузку попадают как раз из него, а необходимо чтобы выгружалось из справочника-родителя, который напрямую с регистром не завязан...
Как получить такое значение через "цепь" связанных справочников?
Yandex
Возможно, вас также заинтересует
Реклама на портале
gorakh
19.04.2013 10:18Ответ № 1
Сначала формируешь таблицу занчений с нужными тебе полями. Потом ее и выгружаеш. А зачем в TXT?
ad82117
19.04.2013 11:18Ответ № 2
я так понял, что нужно получить родителя?
что за регистр и что за справочник?
rt55377
19.04.2013 11:25Ответ № 3
Не совсем понял что именно мне нужно выгрузить в ТЗ...
Вот моя обработка на данный момент:
Код 1C v 7.x
 
Процедура Выгрузить()

Файл = "suppliers.txt";
Путь = "C:\folder\";

Если ФС.ВыбратьФайл(1,Файл,Путь,"Выгрузить взаиморасчёты с поставщиками","Текстовый файл (*.txt)|*.txt")=0 Тогда
СтатусВозврата(0);
Возврат;
КонецЕсли;

Текст = СоздатьОбъект("Текст");
РегПоставщики = СоздатьОбъект("Регистр.Поставщики");
СпрДог = СоздатьОбъект("Справочник.Договоры");
СпрКон = СоздатьОбъект("Справочник.Контрагенты");

РегПоставщики.ВыбратьИтоги();
Пока РегПоставщики.ПолучитьИтог()=1 Цикл

Фирма = Строка(РегПоставщики.Фирма);
Контрагент = Строка(РегПоставщики.Договор.ПолучитьАтрибут("Наименование"));
ВидДолга = Строка(РегПоставщики.ВидДолга);
Документ = Строка(РегПоставщики.КредДокумент);
Долг1 = Строка(РегПоставщики.СуммаВал);
Долг2 = Строка(РегПоставщики.СуммаУпр);
Долг3 = Строка(РегПоставщики.СуммаРуб);
Долг4 = Строка(РегПоставщики.ОценкаРуб);
Стр = Строка(Фирма+" - "+Контрагент+" - "+ВидДолга+" - "+Документ+" - "+Долг1+" - "+Долг2+" - "+Долг3+" - "+Долг4);
Текст.ДобавитьСтроку(Стр);

КонецЦикла;

Текст.Записать(Путь+Файл);
Предупреждение("Выгрузка успешно завершена!");

КонецПроцедуры

// атрибут(измерение) регистра "Поставщики" имеет тип значения "справочник"("Договоры"), который в свою очередь подчинён "Контрагентам", откуда и надо взять значение(в данном случае "Наименование")...
А выгрузку в текст попросили для переноса данных в 8-ку. Всё надо сделать руками *01
Gonzik2
19.04.2013 12:18Ответ № 4
Контрагент = СокрЛП(РегПоставщики.Договор.Владелец.Наименование);
rt55377
10.06.2013 17:02Ответ № 5
Вопрос закрыт!
Подсказка:Вы можете добавить любую страничку в Социальные закладки щелкнув по значку соцсетей (в вверху)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.