helpf.pro
Регистрация

v8: Не формируются движения по регистру бухгалтерии

zan0zzza
23.04.2013 11:32Прочитано: 1610
Создаю документ, в модуле с использованием конструктора движений создается обработка проведения, при проведении документа движения не появляются.
Подскажите, пожалуйста, в чем может быть дело?
Yandex
Возможно, вас также заинтересует
Реклама на портале
sashuly
23.04.2013 11:56Ответ № 1
что за конфигурация? приведите ваш код.
zan0zzza
23.04.2013 12:00Ответ № 2
Конфигурация БП КОРП 2.0.46.8
Вот код процедуры:
title
E_Migachev
23.04.2013 13:56Ответ № 3
(2) zan0zzza, а где движение по СчетДТ?
в настройках Хозрасчетного - 100% стоит Корреспонденция, а при ней без СчетДТ проводка не появится.
zan0zzza
23.04.2013 14:11Ответ № 4
Да, действительно в настройках хозрасчетного стоит Корреспонденция.
Но счет, по которому делаю проводку - забалансовый, проводка по смыслу документа как раз должна быть односторонней.
Как в этом случае быть?
zan0zzza
23.04.2013 14:20Ответ № 5
Сделала движение и по СчетДт, и сумму на всякий случай поставила - все равно движение не появилось)
E_Migachev
23.04.2013 14:23Ответ № 6
(5) zan0zzza, счет ДТ нулевой + субконто по нему
zan0zzza
23.04.2013 14:31Ответ № 7
Так тоже не работает. Или я снова не то делаю?

Код 1C v 8.х
 Процедура ОбработкаПроведения(Отказ, Режим)

Движения.Хозрасчетный.Очистить();
Движения.Хозрасчетный.Записывать = Истина;
Для Каждого ТекСтрокаТовары Из Товары Цикл
Движение = Движения.Хозрасчетный.Добавить();
Движение.СчетКт = ПланыСчетов.Хозрасчетный.ИнвентарьИХозяйственныеПринадлежностиВЭксплуатации;
Движение.СчетДт = "";
Движение.КоличествоДт = "";
Движение.Сумма = 111;
Движение.Период = Дата;
Движение.КоличествоКт = ТекСтрокаТовары.Количество;
Движение.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Номенклатура] = ТекСтрокаТовары.Номенклатура;
Движение.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.ПартииМатериаловВЭксплуатации] = ТекСтрокаТовары.Партия;
Движение.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.РаботникиОрганизаций] = МатериальноОтветственный;
Движение.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Номенклатура] = "";
Движение.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.ПартииМатериаловВЭксплуатации] = "";
Движение.СубконтоДт[ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.РаботникиОрганизаций] = "";

КонецЦикла;

КонецПроцедуры
sashuly
23.04.2013 15:15Ответ № 8
какие у вас стоят настройки в (3)
E_Migachev
23.04.2013 15:51Ответ № 9
(7) zan0zzza, так а счетДТ то укажите, то что он ="" ничего не значит - нужна ссылка на план счетов! и не забудьте поменять субконто у ДТ
zan0zzza
23.04.2013 17:37Ответ № 10
(6) E_Migachev, я не поняла, что такое счет ДТ нулевой + субконто по нему
Пустая ссылка на план счетов?
Код 1C v 8.х
 Движение.СчетДт = ПланыСчетов.Хозрасчетный.ПустаяСсылка();

Тоже не проводится
Кстати, если ставлю счДт такой же как СчКт проводка тоже не появляется
zan0zzza
23.04.2013 17:38Ответ № 11
(8) sashuly, регистр бухгалтерии Хозрасчетный как в типовой БП, его не меняли
E_Migachev
23.04.2013 21:30Ответ № 12
(10) zan0zzza, нужно указать ссылку на счет 000
sashuly
24.04.2013 09:56Ответ № 13
(12) E_Migachev, человек делает проводку по забалансовому счету, проводка может быть без кореспонденции. Тут видимо как-то друга проблема.
sashuly
24.04.2013 10:27Ответ № 14
(11) zan0zzza, вы где смотрите результат в оборотке или журнале проводок?
zan0zzza
24.04.2013 11:25Ответ № 15
(14) sashuly, и в оборотке, и в журнале проводок - движений по этому документу нет.
sashuly
24.04.2013 12:01Ответ № 16
странно конечно, единственное что вижу вы не присваиваете значение реквизиту Организация, но это не должно влиять на журнал проводок.
Специально установил пустую конфу, сделал новый документ, вот абсолютно работающий код:

Код 1C v 8.2 УП
 
Процедура ОбработкаПроведения(Отказ, Режим)
//{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

// регистр Хозрасчетный
Движения.Хозрасчетный.Записывать = Истина;
Движения.Хозрасчетный.Очистить();
Для Каждого ТекСтрокаТабличнаяЧасть1 Из ТабличнаяЧасть1 Цикл
Движение = Движения.Хозрасчетный.Добавить();
Движение.СчетКт = ПланыСчетов.Хозрасчетный.ИнвентарьИХозяйственныеПринадлежностиВЭксплуатации;
Движение.Период = Дата;
// Движение.Организация = Организация;
Движение.Сумма = сумма;
Движение.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.Номенклатура] = ТекСтрокаТабличнаяЧасть1.Номенклатура;
Движение.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.ПартииМатериаловВЭксплуатации] = ТекСтрокаТабличнаяЧасть1.партия;
Движение.СубконтоКт[ПланыВидовХарактеристик.ВидыСубконтоХозрасчетные.РаботникиОрганизаций] = МОЛ;
КонецЦикла;

//}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры

zan0zzza
24.04.2013 12:18Ответ № 17
(16) sashuly, спасибо огромное)
Действительно, не указывала в движениях значение организации, а в журнале проводок стоял автоматический фильтр по организации.
Теперь поправила - в журнале и оборотке движения вижу

Может еще подскажете, почему при нажатии на кнопку ДК на командной панели формы документа и формы списка не открываются проводки этого документа?
sashuly
24.04.2013 12:25Ответ № 18
Если список документов вы делали сами, о вполне возможно в поле действие кнопки ДК не привязана процедура открывающая проводки. Смотрите аналогию в других документах.
zan0zzza
24.04.2013 12:52Ответ № 19
(18) sashuly, еще раз большое спасибо, все сделала)
Подсказка: Вы можете добавить любую страничку в Избранное щелкнув по значку
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.