helpf.pro
Регистрация

Запрет просмотра чужих документов

Aikin
04.12.2009 12:19Прочитано: 4421
Реализовал запрет просмотра пользователями чужих документов(т.е. открыть документ может только автор этого документа), сделал это: В каждом документе в процедуре ПередОткрытием(...) прописал проверку является ли текущии пользователь автором открываемого документа, если нет то Отказ=. Мне кажется этот способ не то чтобы неэфективный но он оказался ужасно трудоемкии, в базе около 50 документов, пришлось обрабатывать каждый. Каким еще способом можно реализовать Запрет доступа просмотра чужих документов?
Код 1C v 8.х
 
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
Если не Новый() Тогда
Если Не РазрешитьПросмотрЧужихДокументов(Ответственный) Тогда

Предупреждение("Недостаточно полномочий для просмотра документов других пользователей!");

Отказ = Истина;

КонецЕсли;


КонецЕсли;
КонецПроцедуры

Yandex
Возможно, вас также заинтересует
Реклама на портале
Aikin
04.12.2009 12:26Ответ № 1
Уточнение: В каждом документе есть реквизит "ответственный" где хранится элемент справочника "Пользователи" тот кто создал документ, и пользователю ставится галочка "Разрешить просмотр чужих документов" в плане видов характеристик спр.Пользователи
E_Migachev
04.12.2009 12:44Ответ № 2
А в какой конфигурации делаешь это?
E_Migachev
04.12.2009 12:58Ответ № 3
В каждом документе в процедуре ПриОткрытии, есть общая для всех документов процедура УстановитьДоступность формы для редактирования.

Вот в ней можно прописать условие проверки на пользователя и если не тот то закрывать документ.
Aikin
04.12.2009 15:21Ответ № 4
Досталась старая управление торговлей переписанная на всю голову, пробовал искать какие нибудь общие функцие которые бы вызывались во всех документах в процедуре ПередОткрытием, таких неоказалось. При откртии конечно есть, но технологически получается то это не верно, отказаться от открытия формы лучше когда она не открылась а не закрывать открытую, я тоже думал чтоб закрывать открытую, мне кажется это нехорошо.
Может ктонибудь пробовал такой фокус с помощью ролей проворачивать?
E_Migachev
04.12.2009 16:20Ответ № 5
Технологически плохо, даже если в друг у кого-то медленный комп или просто сглючит, получится что 1С-ка откроет док, все покажет юзеру и только потом закроется. Но это единственный способ сделать быстро во всех документах.

В ролях если ставить ограничения, то ставить для каждого документа, а это все-равно что прописать в каждом в ПередОткрытием.
SeReGa
07.12.2009 17:30Ответ № 6
Есть такая штука как дополнительная настройка для пользователей. Вот посмотри как сделано(тут правда запрет на изменения ) : http://www.infostart.ru/public/22202/
SeReGa
07.12.2009 17:31Ответ № 7
ой. это для 7.7. ))) сорри.
E_Migachev
10.12.2009 11:57Ответ № 8
Подсказка:Вы можете добавить любую страничку в Социальные закладки щелкнув по значку соцсетей (в вверху)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.