helpf.pro
Регистрация

Передача параметры

Bell
06.05.2013 11:40Прочитано: 1446
Здравствуйте
Имю ТЧ обработки. Хочу при двойной клике передать значение ячейки ( любой ) в произвольную форму.

Как передать значение ячейки табличной части обработки в произвольную форму
Код 1C v 8.х
 Процедура ТаблицаОбработкиВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)



СтандартнаяОбработка = Ложь;

ФормаВыбора = ЭтотОбъект.ПолучитьФорму("ФормаВыбора",ЭтаФорма);

// Код для Таблицы значений
//ФормаВыбора.ПолеВыбраЗначения = ВыбраннаяСтрока[Элемент.Значение.Индекс(Колонка)];
//ВыбранноеЗначениеТЧ = ВыбраннаяСтрока[Элемент.Значение.Индекс(Колонка)];


Если НЕ ФормаВыбора.Открыта() Тогда
ФормаВыбора.ОткрытьМодально();
// код
КонецЕсли;


КонецПроцедуры

Изменено 06.05.13 11:42:38
Yandex
Возможно, вас также заинтересует
Реклама на портале
Mokey
06.05.2013 13:49Ответ № 1
Код 1C v 8.х
 
Если НЕ ФормаВыбора.Открыта() Тогда
// вот сюда вставляем код, в котором заполняем параметры открываемой формы
//значениями из выбранной ячейки, а потом открываем, например
ФормаВыбора.ПолеВыбраЗначения = ВыбраннаяСтрока[Колонка];
ФормаВыбора.ОткрытьМодально();
// код
КонецЕсли;
Bell
06.05.2013 14:48Ответ № 2
Выдает ошибку

{Обработка.ЗагрузкаДанныхИзФайла.Форма.Форма.Форма(210)}: Получение элемента по индексу для значения не определено
ФормаВыбора.ПолеВыбраЗначения = ВыбраннаяСтрока[Колонка];
Mokey
06.05.2013 14:53Ответ № 3
В синтаксисе посмотрите как правильно получить значение колонки в выбранной строке, это я на память написал
Bell
17.05.2013 14:33Ответ № 4
Если на затруднит отпшись у мемя никак с индексом не идет валятся ошибки
Mokey
17.05.2013 14:38Ответ № 5
(4) Bell, какие ошибки?
Bell
20.05.2013 11:56Ответ № 6
Я пробовал по разному это основная ошбика

{Обработка.ЗагрузкаДанных.Форма.Форма.Форма(324)}: Получение элемента по индексу для значения не определено
ФормаВыбора.ПолеВыбораЗначения = СокрЛП(ВыбраннаяСтрока[Колонка]);
Mokey
20.05.2013 12:12Ответ № 7
так а чему равна ВыбраннаяСтрока? или вообще, что это такое в Вашем случае?
Bell
20.05.2013 14:26Ответ № 8
Вот черновой вариант
1. первая строка ТЧ обработки не обрабатыватся (А так вроде все работает)
2 Дальше надо будет делать , найти определенные занчения в ТЧ Определенного столбца (по которому сделали выбор) и заменить на те которые я поставлю в форме выбора

Код 1C v 8.х
 СтрокаТЧ = ЭлементыФормы.ТаблицаОбработки.ТекущиеДанные;
ТК = ЭлементыФормы.ТаблицаОбработки.ТекущаяКолонка;

ФормаВыбора.ПолеВыбораЗначения = СтрокаТЧ[ТК.Имя];

//Сообщить(СтрокаТЧ.Наименование);
//Сообщить(ТК.Имя);

ФормаВыбора.ОткрытьМодально();

Изменено 20.05.13 18:36:11
Bell
22.05.2013 10:23Ответ № 9
Вопрос закрыт!
Подсказка: Вы получили ответ на свой вопрос - закройте вопрос!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.