helpf.pro
Регистрация

v8.2 УП: форма документа

ovel
15.05.2013 15:54Прочитано: 932
Код 1C v 8.х
    

Добрый день.
Перечитала и просмотрела уйму всего, а на деле ничего не получается - примитив, а никак...
есть Регистр накопления ТоварОстатки, как из него вытянуть данные и вставить в новый документ - документ создан, форма тоже, добавила кнопку, написала код, а ничего не запоняется - что не так..

Процедура ЗаполнитьНажатие1(Элемент)
// Вставить содержимое обработчика.
Запрос = Новый Запрос;
Запрос.Текст="ВЫБРАТЬ
|ТоварОстаткиОстатки.Товар,
|ТоварОстаткиОстатки.КоличествоОстаток
|ИЗ
|РегистрНакопления.ТоварОстатки.Остатки КАК ТоварОстаткиОстатки";
РезультатВыполненияЗапроса = Запрос.Выполнить().Выгрузить();
КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
Ermak
15.05.2013 16:34Ответ № 1
А куда ты выгружаешь????

Вот пример

Код 1C v 8.х
 	Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
|АттестуемыеРезультаты.Аттестация,
|АттестуемыеРезультаты.Билет,
|АттестуемыеРезультаты.Дата,
|АттестуемыеРезультаты.Ссылка.Разряд,
|АттестуемыеРезультаты.Ссылка.Должность,
|АттестуемыеРезультаты.Ссылка.ГазУч,
|АттестуемыеРезультаты.Ссылка.Организация,
|АттестуемыеРезультаты.Ссылка.Имя,
|АттестуемыеРезультаты.Ссылка.Отчество,
|АттестуемыеРезультаты.Ссылка.Наименование КАК Фамилия
|ИЗ
|Справочник.Аттестуемые.Результаты КАК АттестуемыеРезультаты
|ГДЕ
|АттестуемыеРезультаты.Дата = &Дата";

Запрос.УстановитьПараметр("Дата",Элемент.Значение);
Результат = Запрос.Выполнить().Выгрузить();
ЭлементыФормы.ТабличноеПоле1.Значение=Результат;

Изменено 15.05.13 16:35:02
ovel
16.05.2013 14:41Ответ № 2
Спасибо, что отвечаете, но уменя опять глупый вопрос - что значит - значение -


Процедура ЗаполнитьНажатие1(Элемент)
// Вставить содержимое обработчика.
Запрос = Новый Запрос;
Запрос.Текст="ВЫБРАТЬ
|ТоварОстаткиОстатки.Товар,
|ТоварОстаткиОстатки.КоличествоОстаток
|ИЗ
|РегистрНакопления.ТоварОстатки.Остатки КАК ТоварОстаткиОстатки
|ГДЕ
|ТоварОстатки.Товар=&Товар";
Запрос.УстановитьПараметр("Товар",Элемент.Значение);
Результат = Запрос.Выполнить().Выгрузить();
ЭлементыФормы.Товары.Значение=Результат;
КонецПроцедуры

Ругается и говорит, что поле объекта не обнаружено

А выгружаю в новый документ - задача стоит просто заполнить его данными из Регистра накопления, где собрана информация от других документов
Ermak
16.05.2013 15:04Ответ № 3
(2) ovel, В твоем случае это

Код 1C v 8.х
 |ГДЕ 
|ТоварОстатки.Товар=&Товар";

это идет отбор по Товару, если тебе нужно просто заполнить без всякого отбора тогда просто напиши

Код 1C v 8.х
 Запрос = Новый Запрос;	
Запрос.Текст="ВЫБРАТЬ
|ТоварОстаткиОстатки.Товар,
|ТоварОстаткиОстатки.КоличествоОстаток
|ИЗ
|РегистрНакопления.ТоварОстатки.Остатки КАК ТоварОстаткиОстатки";

Результат = Запрос.Выполнить().Выгрузить();
ЭлементыФормы.Товары.Значение=Результат;
ЭлементыФормы.Поле.СоздатьКолонки();
КонецПроцедуры


Этим
Код 1C v 8.х
 ЭлементыФормы.Товары.Значение=Результат;   

мы выгружаем данные ТП Товары
Изменено 16.05.13 15:05:15
ovel
16.05.2013 15:48Ответ № 4
Спасибо, что-то подобное я уже делала.. Надо , наверно, проверить , а правильно ли я сделала кнопку, т.к. в прошлый раз отладка говорила, что поле объекта (поле) не обнаружено Еще раз мерси
Ermak
16.05.2013 16:03Ответ № 5
Если ответили на вопрос, тогда нажми внизу Закрыть вопрос?
ovel
16.05.2013 16:13Ответ № 6
А можно сначала все-таки узнать, почему отладка не идет - поле объекта (поле) не обнаружено - я все проверила - и еще не пойму почему в примерах

Процедура КнопкаВыполнитьНажатие(Кнопка) - в скобках кнопка, а у меня Элемент

Процедура КнопкаЗаполнитьНажатие(Элемент)
Ermak
16.05.2013 16:17Ответ № 7
Процедура КнопкаВыполнитьНажатие(Кнопка) - эта кнопка Элемент панели

Процедура КнопкаЗаполнитьНажатие(Элемент) - эта кнопка Элемент формы.
как я понимаю )
ovel
16.05.2013 16:18Ответ № 8
Означает ли это , что я все-таки неправильно сделала кнопку ?
Ermak
16.05.2013 16:27Ответ № 9
закиньте сюда вашу обработку
ovel
16.05.2013 16:30Ответ № 10
Процедура КнопкаЗаполнитьНажатие(Элемент)
// Вставить содержимое обработчика.
Запрос = Новый Запрос;
Запрос.Текст="ВЫБРАТЬ
|ТоварОстаткиОстатки.Товар,
|ТоварОстаткиОстатки.КоличествоОстаток
|ИЗ
|РегистрНакопления.ТоварОстатки.Остатки КАК ТоварОстаткиОстатки";
Результат = Запрос.Выполнить().Выгрузить();
ЭлементыФормы.Товары.Значение=Результат;
ЭлементыФормы.Поле.СоздатьКолонки();
КонецПроцедуры
Ermak
16.05.2013 16:37Ответ № 11
Какие реквизиты на форме?
Может так надо

Код 1C v 8.х
 ЭлементыФормы.Товары.СоздатьКолонки();   
ovel
16.05.2013 16:38Ответ № 12
Попробую, спасибо...
ovel
16.05.2013 16:49Ответ № 13
Если я правильно Вас поняла, то Товар и Количество должны быть реквизитами документа,
а не находиться в табличной части,
а то у меня сейчас реквизит Склад,
табличная часть - Товары : Товар, Количество и КоличествоФакт,
но КоличествоФакт мне автоматически заполнять не надо

Ладно буду пробовать, спасибо огромное....
ovel
16.05.2013 16:52Ответ № 14
Да, забыла ... заменила Поле на Товары и Ура - не ругается,
но и не заполняет,
все рано немного на душе легче - тяжело ощущать себя.......
Ermak
16.05.2013 17:12Ответ № 15
вы можете загрузить обработку вашу на форум
ovel
17.05.2013 13:10Ответ № 16
Уважаемый Ermak, не поняла Вашего последнего ответа - куда и зачем ?
ovel
20.05.2013 16:21Ответ № 17
Процедура КнопкаЗаписатьНажатие(Элемент)
// Вставить содержимое обработчика.
Запрос = Новый Запрос;
Запрос.Текст="ВЫБРАТЬ
|ТоварОстаткиОстатки.Товар,
|ТоварОстаткиОстатки.КоличествоОстаток КАК Количество
|ИЗ
|РегистрНакопления.ТоварОстатки.Остатки КАК ТоварОстаткиОстатки";
Товары.Загрузить(Запрос.Выполнить().Выгрузить());
КонецПроцедуры
ovel
20.05.2013 16:22Ответ № 18
Все работает
Подсказка: Щелникни по Имени пользователя напротив ответа, и тем самым покажешь, что сообщение адресовано ему.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.