helpf.pro
Регистрация

v8: При получении данных

Bell
11.06.2013 13:19Прочитано: 1504
Здравствуйте
Подскажите что не так
Обработка, разменсил таб.поле (ТипЗначения= СправочникСписок.ЗП_Сотрудники)
Добавил две колонки ДатаПриема и ДатаУвальнения
Данные о приеме и увольнении хранятся в регистре сведения. Поместил алгорит в процедура ПриПолученииДанных
Данные по датам не отображаются
Код 1C v 8.х
 Процедура СправочникСписокПриПолученииДанных(Элемент, ОформленияСтрок)

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
|*
|ИЗ
| РегистрСведений.РС_Сотрудники.СрезПоследних(&Дата, Сотрудники В (&МассивСотрудники)) КАК РС_Сотрудник";

МассивСотрудники = Новый Массив;
Соответствие = Новый Соответствие;
Для Каждого Оформление из ОформленияСтрок Цикл
МассивСотрудники.Добавить(Оформление.ДанныеСтроки.Ссылка);
Соответствие.Вставить(Оформление.ДанныеСтроки.Ссылка, Оформление);
КонецЦикла;

Запрос.УстановитьПараметр("Дата",КонецДня(Дата) );
Запрос.УстановитьПараметр("МассивСотрудники", МассивСотрудники);

Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл

Соответствие.Получить(Выборка.Сотрудники.Ссылка).Ячейки.ДатаПриема.Значение = Выборка.ДатаПриема;
Если Выборка.ДатаУвольнения <> Дата('00010101') Тогда // Дата(1,1,1)
Соответствие.Получить(Выборка.Сотрудники.Ссылка).Ячейки.ДатаУвольнения.Значение = Выборка.ДатаУвольнения;
Иначе
Соответствие.Получить(Выборка.Сотрудники.Ссылка).Ячейки.ДатаУвольнения.Значение = "";
КонецЕсли;

КонецЦикла;

КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
Mokey
11.06.2013 14:08Ответ № 1
Может, стоит через УстановитьТекст()?
Соответствие.Получить(Выборка.Сотрудники.Ссылка).Ячейки.ДатаУвольнения.УстановитьТекст(Выборка.ДатаУвольнения);
Изменено 11.06.13 14:09:28
Bell
11.06.2013 14:19Ответ № 2
То же не работает, может это связана как то с тем, что это обработка (ее свойство)
movel
11.06.2013 16:03Ответ № 3

Изменено 11.06.13 16:38:30
Bell
12.06.2013 10:18Ответ № 4
Вопрос закрыт!
Подсказка: Для быстрого поиска ответов - используйте 'Поиск'
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.