helpf.pro
Регистрация

v8.2 УП: Подключение к Excel (управляемые формы)

ice_
09.07.2013 11:31Прочитано: 6697
Есть серверная база, в которой необходимо подключить Excel и вывести в него данные, в файловом варианте все работает. В серверном варианте происходит следующее: при создании нового COM объекта "Excel.Aplication" не вызывает исключительной ситуации, но при этом в качестве возвращаемого значение возвращает значение "Неопределенно". при этом при самом первом проходе доходит в отладке до конца и при этом Excel все же не показывается, ничего не происходит...Не пойму в чем дело, помогите разобраться!!!!
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
09.07.2013 11:39Ответ № 1
(0) ice_, показывай код, как вызываешь
ice_
09.07.2013 11:40Ответ № 2
Функция EXCELСоздатьCOMОбъект()

Excel = Неопределено;

# Если клиент тогда
Состояние("Идет установка связи с в Excel ");
# КонецЕсли

Попытка
Excel = Новый COMОбъект("Excel.Application");
Исключение
# Если клиент тогда
Сообщить("Ошибка создания обьекта Microsoft Excel" + ОписаниеОшибки(),СтатусСообщения.Внимание);
# КонецЕсли
КонецПопытки;

Возврат Excel;

КонецФункции //EXCELСоздатьCOMОбъект
ice_
09.07.2013 11:43Ответ № 3
Может дело в платформе? у меня платформа 1С:Предприятие 8.2 (8.2.18.82)
E_Migachev
09.07.2013 11:47Ответ № 4
(3) ice_, а на сервере установлен Excel? у юзера под которым работает сервер 1С есть права на его использование?
ice_
09.07.2013 11:53Ответ № 5
Мой начальник утверждает, что да, установлен Excel
, проверить самому нет возможности-нет прав, к тому же работаю удаленно! но, при этом запускаю стандартный документ конфигурации УТ 11 Установка цен номенклатуры, в котором есть выгрузка в Excel, также не работает...
Не знаю, с какого конца копать...((
ice_
09.07.2013 12:03Ответ № 6
Еще раз прогнал отладку, видно из нее, что строчка COMОбъект("Excel.Application"); не работает, просто изначально как было значение установлено в значение Неопределенно, так и остается....
E_Migachev
09.07.2013 12:27Ответ № 7
(5) ice_, если и стандартная не работает, то точно косяк в правах, не сервере недоступен COMОбъект("Excel.Application");
чтобы убедиться, установи точку останова и попробуй вычислить COMОбъект("Excel.Application"), что это вернет?
ice_
09.07.2013 12:34Ответ № 8
пробовал,
Excel = Неопределено;
Excel = Новый COMОбъект("Excel.Application");
В качестве значения Excel остается значение Неопределенно, соответственно далее не работает...
E_Migachev
09.07.2013 13:13Ответ № 9
Получается что не может создать com-объект и ткт варианта два:
1. его просто нет
2. не прав у пользователя на работу с сом объетами
3. может конечно глюк и платформы, попробуй новую 18,96 которая
ice_
09.07.2013 13:52Ответ № 10
Разобрался... оказывается надо было Excel вызывать с клиента, а у меня вызывался с сервера, поэтому ничего и не происходило, т.к. все оставалось на сервере, загадка, конечно, что стандартный документ не работает.
СПАСИБО!
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.