helpf.pro
Регистрация

Регламентные задание

SOBOLEV
14.09.2010 14:01Прочитано: 3297
у меня файловая система . я создал пользователя с прорвами администратор запустил обработку у меня она срабатывает каждые 3 секунда. Теперь чтобы выполнялись регламентные задание мне нужно под этим пользователем заходить и они будут в определенное время срабатывать??? ещё мне сказали посмотреть срабатывает ли обработка в журнале регистрации где это там видно??
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
14.09.2010 14:52Ответ № 1
Я так понимаю это продолжение темы Как на календарь назначить задачи!
Ну так вот:
Теперь если ты хочешь чтобы выполнялись регламентные задания, то запускаешь базу под этим пользователем и обработку! - пока открыта база и запущена обработка Регламентные задания буду выполнятся согласно установленному в них расписанию!

В Журнале Регистрации во время указанное в Расписание как Начало, должна появится запись о начале выполнения задания и позже запись о завершении или о возникшей ошибке!
SOBOLEV
14.09.2010 15:01Ответ № 2
да спасибо щас попробую+)
SOBOLEV
14.09.2010 15:42Ответ № 3
а можно пример самой простой процедуры которую можно записать в модуль для выполнения регламентных задачь
E_Migachev
14.09.2010 16:04Ответ № 4
(3) SOBOLEV, самое простое это например:
Код 1C v 8.х
 ЗначениеВФайл("C:\123.txt", "Тест");   

После выполнения на диске С появится файл 123 в нем слово Тест
А вот пример переноса данных Автоматическая выгрузка загрузка данных используя регламентное задание
SOBOLEV
14.09.2010 16:08Ответ № 5
там кода нет пуста+)
E_Migachev
14.09.2010 16:12Ответ № 6
(5) где кода нет?
SOBOLEV
14.09.2010 16:13Ответ № 7
ответ 4+)
E_Migachev
14.09.2010 16:18Ответ № 8
через IE сидишь?
в (4) такой код: ЗначениеВФайл("C:\123.txt", "Тест");
SOBOLEV
14.09.2010 16:21Ответ № 9
да через него
E_Migachev
14.09.2010 16:29Ответ № 10
(9) в IE многие вещи почти на всех сайтах не отображаются корректно *11
советую использовать Mozilla FireFox или Opera
SOBOLEV
14.09.2010 16:31Ответ № 11
вот смотри всё сделал в модуль вставил код назначал время зашел под нужным пользователем включил обработку и жду выполнения регламентных задача но нечего не происходит в чем может быть причина?
SOBOLEV
14.09.2010 16:32Ответ № 12
а я уже у калеги через мазилу посматрел+)) всё вставил там уже следующий вапрос вылез+)
E_Migachev
14.09.2010 16:38Ответ № 13
(11) расписание как указал?
E_Migachev
14.09.2010 16:40Ответ № 14
+ (13) Вот подробнее про Регламентные задания
SOBOLEV
14.09.2010 16:47Ответ № 15
=)) у него както получилось он мне создал блакнотьт но без слова тест что то работает это уже хорошо+) ещё вопросик мне надо весь код отчёта писать чтобы он его вывел или можно как то подругому???
E_Migachev
14.09.2010 16:53Ответ № 16
А какой отчет?
код покажи?
SOBOLEV
14.09.2010 16:55Ответ № 17
и ещё вопрос допустим всё получилось и таким метадом всё выводится возможноли сделать так что при запуске роли метадист автоматически вазывалась и эта роль и выполняла бы свои функции по вываду отчётов в нужное время.
SOBOLEV
14.09.2010 16:56Ответ № 18
Функция ЗапросОценки (Студент, Предмет)
Запрос = Новый Запрос;


Запрос.Текст = "ВЫБРАТЬ
| ЭкзаменационнаяВедомостьСрезПоследних.Результат,
| ЭкзаменационнаяВедомостьСрезПоследних.Студент,
| ЭкзаменационнаяВедомостьСрезПоследних.Дисциплина
|ИЗ
| РегистрСведений.ЭкзаменационнаяВедомость.СрезПоследних(&Дата, ) КАК ЭкзаменационнаяВедомостьСрезПоследних
|ГДЕ
| ЭкзаменационнаяВедомостьСрезПоследних.Студент = &студент
| И ЭкзаменационнаяВедомостьСрезПоследних.Дисциплина =&Дисциплина";

Запрос.УстановитьПараметр("Дата",Дата);
Запрос.УстановитьПараметр("Дисциплина",Предмет);
Запрос.УстановитьПараметр("Семестр",Семестр);
Запрос.УстановитьПараметр("студент",Студент);

Результат = Запрос.Выполнить().Выгрузить();
Возврат результат[0].Результат;

КонецФункции


Процедура КнопкаСформироватьНажатие(Кнопка)
// Вставить содержимое обработчика.

если ПустаяСтрока(Дата)= истина тогда
Сообщить("Не заполнена дата");
возврат;
КонецЕсли;

если ПустаяСтрока(Группа)= истина тогда
Сообщить("Не заполнена Группа");
возврат;
КонецЕсли;

если ПустаяСтрока(Семестр)= истина тогда
Сообщить("Не заполнена Семестр");
возврат;
КонецЕсли;

//Запрос на Экзамены
Запрос = Новый Запрос;
Запрос.Текст ="ВЫБРАТЬ РАЗЛИЧНЫЕ
| УчебныйПланСрезПоследних.Дисциплины
|ИЗ
| РегистрСведений.УчебныйПлан.СрезПоследних(&Дата, ) КАК УчебныйПланСрезПоследних
|ГДЕ
| УчебныйПланСрезПоследних.Группа = &Группа
| И УчебныйПланСрезПоследних.Семестр = &Семестр
| И УчебныйПланСрезПоследних.ВидАтестации = &ВидАтестации";

Запрос.УстановитьПараметр("Дата",Дата);
Запрос.УстановитьПараметр("Группа",Группа);
Запрос.УстановитьПараметр("Семестр",Семестр);
Запрос.УстановитьПараметр("ВидАтестации",Перечисления.Аттестация.Экзамен);
Экзамены=Запрос.Выполнить().Выгрузить();
Экзамены.Сортировать("Дисциплины Возр",);

//Запрос на Зачеты
Запрос = Новый Запрос;
Запрос.Текст ="ВЫБРАТЬ РАЗЛИЧНЫЕ
| УчебныйПланСрезПоследних.Дисциплины
|ИЗ
| РегистрСведений.УчебныйПлан.СрезПоследних(&Дата, ) КАК УчебныйПланСрезПоследних
|ГДЕ
| УчебныйПланСрезПоследних.Группа = &Группа
| И УчебныйПланСрезПоследних.Семестр = &Семестр
| И УчебныйПланСрезПоследних.ВидАтестации = &ВидАтестации";

Запрос.УстановитьПараметр("Дата",Дата);
Запрос.УстановитьПараметр("Группа",Группа);
Запрос.УстановитьПараметр("Семестр",Семестр);
Запрос.УстановитьПараметр("ВидАтестации",Перечисления.Аттестация.Зачёт);
Зачеты=Запрос.Выполнить().Выгрузить();


Макет = ПолучитьМакет("ИтогиСессии");
ТабДок = Новый ТабличныйДокумент;
ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
ОбластьШапка.Параметры.Семестр = Семестр;
ОбластьШапка.Параметры.Группа = Группа;


Попытка
ОбластьШапка.Параметры.Экзамен1 =Экзамены[0].Дисциплины;
ОбластьШапка.Параметры.Экзамен2 =Экзамены[1].Дисциплины;
ОбластьШапка.Параметры.Экзамен3 =Экзамены[2].Дисциплины;
ОбластьШапка.Параметры.Экзамен4 =Экзамены[3].Дисциплины;
ОбластьШапка.Параметры.Экзамен5 =Экзамены[4].Дисциплины;
Исключение
КонецПопытки;

Попытка
ОбластьШапка.Параметры.Зачет1 =Зачеты[0].Дисциплины;
ОбластьШапка.Параметры.Зачет2 =Зачеты[1].Дисциплины;
ОбластьШапка.Параметры.Зачет3 =Зачеты[2].Дисциплины;
ОбластьШапка.Параметры.Зачет4 =Зачеты[3].Дисциплины;
ОбластьШапка.Параметры.Зачет5 =Зачеты[4].Дисциплины;
Исключение
КонецПопытки;


ТабДок.Вывести(ОбластьШапка);


ОбластьСтудент = Макет.ПолучитьОбласть("Студент");

Выборка = Справочники.Студенты.Выбрать();
пп = 0;


Пока Выборка.Следующий() Цикл
Выборка2 = выборка.ПолучитьОбъект();
если выборка2.ЗачислениеГруппа.Ссылка = Группа Тогда



ОбластьСтудент.Параметры.Студент = Выборка2.Наименование;
пп = пп+1;
ОбластьСтудент.Параметры.пп = пп;


попытка ОбластьСтудент.Параметры.РезЭкз1 = ЗапросОценки(выборка2.Ссылка, Экзамены[0].Дисциплины)исключение конецПопытки;
попытка ОбластьСтудент.Параметры.РезЭкз2 = ЗапросОценки(выборка2.Ссылка, Экзамены[1].Дисциплины)исключение конецПопытки;
попытка ОбластьСтудент.Параметры.РезЭкз3 = ЗапросОценки(выборка2.Ссылка, Экзамены[2].Дисциплины)исключение конецПопытки;
попытка ОбластьСтудент.Параметры.РезЭкз4 = ЗапросОценки(выборка2.Ссылка, Экзамены[3].Дисциплины)исключение конецПопытки;
попытка ОбластьСтудент.Параметры.РезЭкз5 = ЗапросОценки(выборка2.Ссылка, Экзамены[4].Дисциплины)исключение конецПопытки;

попытка ОбластьСтудент.Параметры.РезЗач1 = ЗапросОценки(выборка2.Ссылка, Зачеты[0].Дисциплины)исключение конецПопытки;
попытка ОбластьСтудент.Параметры.РезЗач2 = ЗапросОценки(выборка2.Ссылка, Зачеты[1].Дисциплины)исключение конецПопытки;
попытка ОбластьСтудент.Параметры.РезЗач3 = ЗапросОценки(выборка2.Ссылка, Зачеты[2].Дисциплины)исключение конецПопытки;
попытка ОбластьСтудент.Параметры.РезЗач4 = ЗапросОценки(выборка2.Ссылка, Зачеты[3].Дисциплины)исключение конецПопытки;
попытка ОбластьСтудент.Параметры.РезЗач5 = ЗапросОценки(выборка2.Ссылка, Зачеты[4].Дисциплины)исключение конецПопытки;

//ОбластьСтудент.Параметры.РезЭкз2 = ЗапросОценки(выборка2.Ссылка, Экзамены[1].Дисциплины);
//ОбластьСтудент.Параметры.РезЭкз3 = ЗапросОценки(выборка2.Ссылка, Экзамены[2].Дисциплины);
//ОбластьСтудент.Параметры.РезЭкз4 = ЗапросОценки(выборка2.Ссылка, Экзамены[3].Дисциплины);
//ОбластьСтудент.Параметры.РезЭкз5 = ЗапросОценки(выборка2.Ссылка, Экзамены[4].Дисциплины);
// исключение
// КонецПопытки;

ТабДок.Вывести(ОбластьСтудент);
КонецЕсли;
Конеццикла;



//Запрос на оценки




ТабДок.Показать();
КонецПроцедуры
E_Migachev
14.09.2010 17:11Ответ № 19
(17) Сделай ярлык запуска базы под этим пользователем и помести его в Автозагрузку, при загрузке компа сразу будет запускаться или помести на рабочем столе, и когда нужно пусть запускает!
(18) Вроде код нормальный, должен пройти *13
тока ТабДок.Показать(); замени на ТабДок.Записать(ФайлСохранения, Тип)
SOBOLEV
15.09.2010 08:46Ответ № 20
Доброе утро когда-то мне скидывали Консоль заданий и Запуске Регламентных заданий
В консоли заданий мы выберем уже сделанное задаём ему расписание
С низу в консоли заданий появляется Фоновое задание что там писать нужно??? я так понимаю без него Запуск Регламентных заданий не заработает?
E_Migachev
15.09.2010 09:26Ответ № 21
(20) внизу писать ничего не нужно, это история выполненых заданий и отображение выполняющихся заданий
Запуск заданий выполняется только по заданному расписанию!
SOBOLEV
15.09.2010 09:47Ответ № 22
с 8:00:00 по 11:12:00 каждые 5 сек., завершать после 11:11:11 вот маё расписание вчера один разок получилось его выполнить на половину создался текст документ без натписи внутри
всё делал как в подборке сделано так почему может не выполнятся?
E_Migachev
15.09.2010 09:57Ответ № 23
а дни отметил?
SOBOLEV
15.09.2010 10:09Ответ № 24
дату начала и дату окончания вот допустим если я задал 15.09.2009 окончания 20.09.2009 выполнять каждый день и время задано так как скоро оно должно выполняется в промежутке с 8:00:00 по 11:12:00 каждые 5 сек или оно должно сразу выполнится как я обработку включил????
E_Migachev
15.09.2010 10:32Ответ № 25
(24) Когда на сервере, то выполняется сразу! В файловом варианте не уверен!
Попробуй перезайти под пользователем регламент!
SOBOLEV
15.09.2010 15:57Ответ № 26
а где можно посматреть ошибки регламентных заданий в файловом вареанте где пишится ошибка?
E_Migachev
15.09.2010 16:01Ответ № 27
Все пишется в Журнал Регистрации - При условии что в Конфигураторе базы, в Администрирование - Настройка Журнала регистрации выбрано Регистрировать ошибки, предупреждения, информацию, примечания
SOBOLEV
15.09.2010 16:31Ответ № 28
галка стаит но нечего невидно ну до ладно ещё воросик в модуле какие калочки должны стоять
Клиент
Сервер
Внешнее соединение
Привелегированый
E_Migachev
15.09.2010 16:56Ответ № 29
Клиент
Сервер - тоже поставь, вдруг потом перейдут на серверную версию
SOBOLEV
15.09.2010 16:59Ответ № 30
а там полюбому приходится ставить сервер=) там без этого в регламентных заданиях имя метода не выбирается+)
SOBOLEV
16.09.2010 11:54Ответ № 31
понел в чём у меня была ошибка
1) процедуры должны стоять так а я всё на оборот сделал

Процедура КнопкаВыполнитьНажатие(Кнопка)
ПодключитьОбработчикОжидания("ОбработкаЗаданий", 3);
КонецПроцедуры

Процедура ОбработкаЗаданий()
ВыполнитьОбработкуЗаданий();
КонецПроцедуры
и галочка должна стоять на Предопределенное в регламентном задании в общем вот спасибо за помощь буду сейчас пытаться отчёт сделать)
SOBOLEV
16.09.2010 11:54Ответ № 32
Вопрос закрыт!
Подсказка: Щелникни по Имени пользователя напротив ответа, и тем самым покажешь, что сообщение адресовано ему.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.