helpf.pro
Регистрация

Изменить объект

Kamil
06.08.2013 10:54Прочитано: 634
Добрый день! При загрузке номенклатуры с Excel поиск стоит по коду и если есть то нужно получить этот объект и пере заменить то что нужно и в конце ставлю команду Записать но не записывает... В чем причина подскажите пожалуйста??? Вот код и запрос
Изменено 06.08.13 11:13:43
Yandex
Возможно, вас также заинтересует
Реклама на портале
Kamil
06.08.2013 11:14Ответ № 1
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Номенклатура.Ссылка,
| Номенклатура.Наименование,
| Номенклатура.Артикул
|ИЗ
| Справочник.Номенклатура КАК Номенклатура
|ГДЕ
| Номенклатура.Код = &Код";

//| И Номенклатура.Наименование = &Наименование
//Запрос.УстановитьПараметр("Наименование", Наименование);

Запрос.УстановитьПараметр("Код", Код);
Результат = Запрос.Выполнить();
ВыборкаНом = Результат.Выбрать();
Пока ВыборкаНом.Следующий() Цикл
НайденнаяСсылка = ВыборкаНом.Ссылка ;
КонецЦикла;


Если НЕ НайденнаяСсылка = "" ТОгда
Товар = НайденнаяСсылка.ПолучитьОбъект();
Товар.ВидНоменклатуры = УправлениеПользователями.ПолучитьЗначениеПоУмолчанию(глТекущийПользователь, "ОсновнойВидНоменклатуры");
Если ЕдИзмр = "упак" Тогда
Товар.БазоваяЕдиницаИзмерения = ЕдИзмУпак;
Товар.Весовой = Ложь;
иначе
Если ЕдИзмр = "шт" Тогда
Товар.БазоваяЕдиницаИзмерения = ЕдИзмШт;
Товар.Весовой = Ложь;
иначе
Если ЕдИзмр = "кг" Тогда
Товар.БазоваяЕдиницаИзмерения = ЕдИзмКг;
Товар.Весовой = Истина;
иначе
Если ЕдИзмр = "флак" Тогда
Товар.БазоваяЕдиницаИзмерения = ЕдИзмФл;
Товар.Весовой = Ложь;
иначе
Если ЕдИзмр = "набор" Тогда
Товар.БазоваяЕдиницаИзмерения = ЕдИзмНаб;
Товар.Весовой = Ложь;
иначе
Если ЕдИзмр = "бут" Тогда
Товар.БазоваяЕдиницаИзмерения = ЕдИзмБут;
Товар.Весовой = Ложь;
иначе
Если ЕдИзмр = "л" Тогда
Товар.БазоваяЕдиницаИзмерения = ЕдИзмЛ;
Товар.Весовой = Ложь;

КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;
Попытка

Товар.Записать();
Сообщить("Элемент с кодом ["+Код+"] в справочнике изменен!");
Исключение
Сообщить("Элемент с кодом ["+Код+"] не удалось изменить!");
КонецПопытки;

КонецЕсли;
E_Migachev
06.08.2013 12:22Ответ № 2
так НайденнаяСсылка определяется?
Kamil
06.08.2013 12:30Ответ № 3
Все решил вопрос! Спасибо!!!
Kamil
06.08.2013 12:30Ответ № 4
Вопрос закрыт!
Подсказка: Для выделения Кода используйте (в редакторе).
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.