helpf.pro
Регистрация

v8: Открыть форму модально по ссылке на документ

IvanDorn
22.08.2013 12:05Прочитано: 5061
Имеется записанный документ. Необходимо открыть именно его форму и модально.

Код 1C v 8.2 УП
    
Yandex
Возможно, вас также заинтересует
Реклама на портале
Kamil
22.08.2013 12:14Ответ № 1
Напиши код...
Jonsony
22.08.2013 14:11Ответ № 2
для начала его надо найти в БД, выбрать и уж потом открыть только
IvanDorn
22.08.2013 20:47Ответ № 3
//для начала его надо найти в БД, выбрать и уж потом открыть только
Нашел, ссылка есть, а как открыть модально-то?
Я знаю что можно открыть форму по ссылке так: ОткрытьЗначение(Ссылка);
Так открывается форма моего нужного документа, но не модально! Как сделать чтобы открылась модально?
E_Migachev
22.08.2013 22:24Ответ № 4
(0) IvanDorn, как-то так
Код 1C v 8.х
  Форма = ДокументСсылка.ПолучитьФорму();
Результат = Форма.ОткрытьМодально();
Если Результат = Неопределено Тогда
Возврат;
КонецЕсли;
Jonsony
23.08.2013 10:28Ответ № 5
вот рабочий код из обработки, сам писал, сам проверял
8.2 УП
место выполнения - &НаКлиенте
Код 1C v 8.2 УП
 
Процедура ВыбратьДокументы(Команда)

ЗначениеОтбора = Новый Структура("СкладОтправитель", Магазин);
ЗначениеОтбора = Новый Структура("СкладПолучатель", Магазин);
ПараметрыВыбора = Новый Структура("ЗакрыватьПриВыборе, МножественныйВыбор, Отбор", Истина, Истина, ЗначениеОтбора);
РезультатОтбора = ОткрытьФормуМодально("Документ.ПеремещениеТоваров.ФормаВыбора", ПараметрыВыбора);

// обработаем результаты нашего отбора

Если РезультатОтбора <> Неопределено Тогда

КонецЕсли;

КонецПроцедуры

по кнопке на форме открывается форма выбора для подбора документов,
предварительно отбирает по "Магазин"
Изменено 23.08.13 10:31:20
IvanDorn
23.08.2013 13:19Ответ № 6
(4) E_Migachev, не работает.
(5) Jonsony, работает.
Всем спасибо за советы. Отдельное спасибо Jonsony!
IvanDorn
24.08.2013 08:46Ответ № 7
Вопрос закрыт!
Подсказка: Щелкнув по значку (справа от названия вопроса), вы получите список ответов на похожие вопросы!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.