helpf.pro
Регистрация

v8.2 УП: Итог

Kamil
29.08.2013 15:07Прочитано: 603
Как взять итог с Цикла например была продажа Налом и безнала Прдаж было 2 по 500 рублей для каждой продажи налом 200 и безнала 300... Итоговая Сумма Налом будет 400 и Безнала 600

Код
Для каждого СтрОплата Из ОплатаНалБезнал Цикл
Если СтрОплата.КодОплаты = 4 Тогда
Сумма =СтрОплата.СуммаНалБезнал ; //Нужна уже итоговая сумма 600 рублей БезНала
Иначе
Сумма1 =СтрОплата.СуммаНалБезнал; //Нужна уже итоговая сумма 400 рублей Налом
Yandex
Возможно, вас также заинтересует
Реклама на портале
Kamil
29.08.2013 15:17Ответ № 1
Когда пишу так

Для каждого СтрОплата Из ОплатаНалБезнал Цикл
Если СтрОплата.КодОплаты = 4 Тогда
Сумма = СтрОплата.Итог("СуммаНалБезнал");
Иначе
Сумма1 = СтрОплата.Итог("СуммаНалБезнал");
КонецЕсли;
КонецЦикла;

Выходит ошибка
{Форма.Форма.Форма(2478)}: Метод объекта не обнаружен (Итог)
Сумма = СтрОплата.Итог("СуммаНалБезнал");
Mokey
29.08.2013 16:21Ответ № 2
ОплатаНалБезнал.Итог("СуммаНалБезнал");

только в цикл зачем входить? непонятно. Тут надо другие методы юзать, или, если уж в цикл вошли, то суммировать СуммаНалБезнал в переменную, например:

СуммаБезнал = 0;
СуммаНал = 0;
Для каждого СтрОплата Из ОплатаНалБезнал Цикл
Если СтрОплата.КодОплаты = 4 Тогда
СуммаБезнал = СуммаБезнал + СтрОплата.СуммаНалБезнал;
Иначе
СуммаНал = СуммаНал + СтрОплата.СуммаНалБезнал;
КонецЕсли;
КонецЦикла;
Изменено 29.08.13 16:21:46
Kamil
02.09.2013 14:55Ответ № 3
Спасибо все Ок!!!
Подсказка: Щелникни по Имени пользователя напротив ответа, и тем самым покажешь, что сообщение адресовано ему.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.