helpf.pro
Регистрация

v8: Програмнное создание документа, глюки или что?

Jonsony
30.08.2013 08:20Прочитано: 1007
имеем код
Код 1C v 8.2 УП
 
&НаКлиенте
Процедура Загрузить(Команда)
СоздатьДокументПродаж()
КонецПроцедуры

&НаСервере
Процедура СоздатьДокументПродаж()
ДокПродаж = Документы.ОтчетОРозничныхПродажах.СоздатьДокумент();

//ДокПродаж.Дата = КонецДня(ТекущаяДата());
//ДокПродаж.Организация = КассаМагазина.Владелец;
//ДокПродаж.Склад = ЗагружаемыйМагазин;
//ДокПродаж.КассаККМ = КассаМагазина;
КонецПроцедуры


а при попытке имеем
Код 1C v 8.2 УП
 
{Форма.Форма.Форма(355)}: Поле объекта не обнаружено (ОтчетОРозничныхПродажах)
Новыйдокумент = Документы.ОтчетОРозничныхПродажах.СоздатьДокумент();

что ему надо? УТ11.1.+ и 8.2.18.96+
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
30.08.2013 11:30Ответ № 1
(0) Jonsony, а название Документа точно верное?

вот у меня работает такой код:
Код 1C v 8.2 УП
 &НаСервере
Функция СоздатьДокументБланкЗаказа(тд)

попытка
НачатьТранзакцию();
//
БланкЗаказа = Документы.БланкЗаказа.СоздатьДокумент();
БланкЗаказа.Дата = ТекущаяДата();

БланкЗаказа.Email = Объект.Email;
БланкЗаказа.Фирма = Объект.Фирма;
БланкЗаказа.Автор = Объект.Автор;
БланкЗаказа.Важность = Объект.Важность;

БланкЗаказа.Скидка = Объект.Скидка;
БланкЗаказа.ДатаЦен = Объект.ДатаЦен;
БланкЗаказа.ВидОплаты = Перечисления.ВидОплаты.Оплачено;
БланкЗаказа.Контрагент = Объект.Контрагент;


БланкЗаказа.МестоЗабора = ?(ЗначениеЗаполнено(БланкЗаказа.Учреждение.МестоЗабора),БланкЗаказа.Учреждение.МестоЗабора, Объект.МестоЗабора);
БланкЗаказа.МестоВыдачи = БланкЗаказа.МестоЗабора;
БланкЗаказа.ПрефиксВыгрузки = Объект.ПрефиксЗапроса;
ИтоговаяСумма = ТаблицаИсследованийСерв.Итог("Цена");
БланкЗаказа.СуммаДокумента = ИтоговаяСумма-(ИтоговаяСумма*Объект.Скидка.Процен/100);
БланкЗаказа.СуммаОплаты = БланкЗаказа.СуммаДокумента;

БланкЗаказа.Исследования.Загрузить(ТаблицаИсследованийСерв);
Для Каждого стр из БланкЗаказа.Исследования Цикл
стр.Артикул = стр.Наименование.Артикул;
стр.КолВо = 1;
стр.Сумма = стр.Цена;
КонецЦикла;

БланкЗаказа.Записать(РежимЗаписиДокумента.Запись);
//
ЗафиксироватьТранзакцию();
Возврат БланкЗаказа.Ссылка;
исключение
ОтменитьТранзакцию();
конецПопытки;

КонецФункции

&НаКлиенте
Процедура Создать(Команда)
ДокСсылка = СоздатьДокументБланкЗаказа(ТД);
ОткрытьЗначение(ДокСсылка);
ЭтаФорма.Закрыть();
КонецПроцедуры
Jonsony
30.08.2013 11:52Ответ № 2
(1) E_Migachev, в том то и дело что имя правильное (оно на другие документы так же реагирует, например ОтчетКомиссионера), и конфа рабочая, типовая (не правленная) ут11.1, что демо, что пустая
и Процедуру, и Функцию тоже пробывал
посылает гадость нафик

и в транзакцию пихал тоже

код команды и до и после ставил, пофигу, что за собака такая?
Изменено 30.08.13 11:53:25
Jonsony
30.08.2013 12:03Ответ № 3
И через "." тоже всё выбирал набирая строку кода.

ДокПродаж = Документы "." ОтчетОРозничныхПродажах "." СоздатьДокумент();
E_Migachev
30.08.2013 12:11Ответ № 4
(3) Jonsony, странно )(
а так что отладчик возвращает?
Код 1C v 8.х
 Документы["ОтчетОРозничныхПродажах"]   
Jonsony
30.08.2013 13:11Ответ № 5
то самое что описал выше "Поле объекта не обнаружено (ОтчетОРозничныхПродажах)"
E_Migachev
30.08.2013 15:55Ответ № 6
а какой тип у Документы???
Jonsony
02.09.2013 10:00Ответ № 7
(6) E_Migachev, ничего там нету
в значении стоит "Поле объекта не обнаружено (ОтчетОРозничныхПродажах)"
а в типе по сему пусто
тут глюк в самой обработке выходит
ибо создаю новую пустую обработку
кидаю на форму одну кнопку и копирую тот же код что не работал
из процедуры команды вызываеться процедура где создаёться новый документ очтета продаж с установкой времени и записываетсья докумен.
и всё проходит на ура
а где глюк это обработки - хбз

придётMся переписывать обработку с нуля в чистой
E_Migachev
02.09.2013 10:55Ответ № 8
(7) Jonsony, скорее всего в ней есть реквизит Документы или ТЧ, измени их имя
Jonsony
02.09.2013 11:30Ответ № 9
(8) E_Migachev, в смысле совпадающие? я сразу избегаю подобных, от 7.7 ещё повелось

у формы всего один реквизит
"Документы" с типом = "ДокументСсылка.ПеремещениеТоваров"

PS
мать их за ногу
заменил "Документы" на "ДокументыПеремещения" и прошло
гады
Jonsony
02.09.2013 11:31Ответ № 10
(8) E_Migachev, Спасибо.
Вопрос закрываю.
Подсказка: Для выделения Кода используйте (в редакторе).
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.