helpf.pro
Регистрация

Разделение интерфейсов, разные списки документов для пользователей

SOBOLEV
17.09.2010 08:53Прочитано: 1240
Доброе утро у меня вопрос возник , у меня два методиста один очное отделение другой заочное у них разные интерфейсы хотелось бы сделать так
1) когда оба методиста работают каждому при в ходе предлагается документ ну допустим расписания студентов соответственно методисту очного отделения расписание групп очного отделения методисту заочного отделения соответственно расписание заочного но когда один из методист не вошел в систему его расписание предлагается методисту вошедшему в базу плюс его собственное.
В каких средствах можно это реализовать ??
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
17.09.2010 09:51Ответ № 1
Предлагаю в форме списка документов наложить отбор по Методостам, например
Вася - очное
Петя - заочное

И код примерно такой (где-то мог ошибится, поправь меня как проверишь ) ):
Код 1C v 8.х
 Процедура СписокДокументовОбновить()
//Призан того что Показывать
ПризнакПоказа = "все";
//Получим Пользователей Работающих в Базе
МассивСоединений = ПолучитьСоединенияИнформационнойБазы();
Для Каждого Соединение из МассивСоединений цикл
Если ИмяПользователя() = "Вася" Тогда
Если Соединение.Пользователь.Имя = "Петя" Тогда
ПризнакПоказа = "очное";
Конецесли;
ИначеЕсли ИмяПользователя() = "Петя" Тогда
Если Соединение.Пользователь.Имя = "Вася" Тогда
ПризнакПоказа = "заочное";
Конецесли;
КонецЕсли;
КонецЦикла;

//В соответсвии с получившимся признаком нужно в Списке отобрать документы
// В документе должен быть Реквизит ТипДокумента в котором указывает какой это документ очный или заочный
Если ПризнакПоказа = "все" Тогда
ДокументСписок.Отбор.Сбросить();
Иначе
ДокументСписок.Отбор.Сбросить();
ДокументСписок.Отбор.ТипДокумента.ВидСравнения=ВидСравнения.Содержит;
ДокументСписок.Отбор.Статус.Значение=ПризнакПоказа;
ДокументСписок.Отбор.Статус.установить();
КонецЕсли;
КонецПроцедуры

//Обработчик проверки через 3 секунды
ПодключитьОбработчикОжидания("СписокДокументовОбновить", 3);
SOBOLEV
21.09.2010 09:19Ответ № 2
идею откланил преподователь+(
Подсказка: Вы можете приложить к ответу файл или изображение щелкнув по значку или в редакторе.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.