helpf.pro
Регистрация

v8: КартСчета физ лиц

Kamil
17.09.2013 15:03Прочитано: 1365
Добрый день! При загрузке физ лиц с Excel нужно и КартСчета к ним создать как сделать можете подсказать... Вот код

Если НайденнаяСсылка = "" Тогда



ФизЛица= Справочники.ФизическиеЛица.СоздатьЭлемент();
ФизЛица.Наименование = Наименование;
ФизЛица.ИдентификационныйКодЛичности = ИИН;
ФизЛица.Записать();
Сообщить("Создан новый элемент: "+ФизЛица.Наименование);
НайденнаяСсылка = ФизЛица.Ссылка;
Иначе Сообщить("Элемент с наименование " + Наименование+ " в справочнике найден");
КонецЕсли;

СтрокаТаблицы.ФизЛица = НайденнаяСсылка;

ФизЛицоВладелец = СтрокаТаблицы.ФизЛица;

Фамилия=СокрЛП(Лев(ФизЛицоВладелец,Найти(ФизЛицоВладелец," ")));
Имя=СокрЛП(Сред(ФизЛицоВладелец,Найти(ФизЛицоВладелец," ")+1));
Имя1=СокрЛП(Лев(Имя,Найти(Имя," ")));
Отчество=СокрЛП(Сред(Имя,Найти(Имя," ")));


Набор = РегистрыСведений.ФИОФизЛиц.СоздатьНаборЗаписей();
ФизЛицо = ФизЛицоВладелец;
Набор.Отбор.ФизЛицо.Установить(ФизЛицоВладелец);
Набор.Отбор.Период.Установить(ТекущаяДата());
Набор.Прочитать();
Если Набор.Количество() = 0 Тогда
СтрокаДанных = Набор.Добавить();
СтрокаДанных.ФизЛицо=ФизЛицоВладелец;
СтрокаДанных.Период = ТекущаяДата();
СтрокаДанных.Фамилия=Фамилия;
СтрокаДанных.Имя=Имя1;
СтрокаДанных.Отчество=Отчество;
Набор.Записать();
Иначе
Сообщить("На"+ФизЛицоВладелец+" уже создан ФИО");
КонецЕсли;
КонецЦикла;
Изменено 17.09.13 15:09:50
Yandex
Возможно, вас также заинтересует
Реклама на портале
Kamil
18.09.2013 09:05Ответ № 1
Вопрос закрыт!
Подсказка: Для редактирования своего ответа щелкните по значку (справа)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.