helpf.pro
Регистрация

Построение графиков?

SOBOLEV
21.09.2010 09:20Прочитано: 4979
Возможноли в 1с построение графиков?
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
21.09.2010 09:47Ответ № 1
(0) да, смотри примеры здесь!
SOBOLEV
21.09.2010 16:01Ответ № 2
какой элемент надо добавить на форму когда нужно построить Диаграмма ?
IKSparrow
21.09.2010 16:07Ответ № 3
Собственно, сам объект Диаграмма и нужно добавить на форму.
SOBOLEV
21.09.2010 16:10Ответ № 4
а в нём настройки нужно какието особые ставить
SOBOLEV
21.09.2010 16:28Ответ № 5
Диаграмма.Серии.Добавить("Номенклатура"); - что значит серии
Диаграмма.Точки.Добавить("Склад");
Диаграмма.Ресурсы.Добавить("КоличествоПриход");
что значит серии, Точки, Ресурсы.?
E_Migachev
21.09.2010 16:41Ответ № 6
(5) Диаграмма представляет собой некую матрицу M x N.
Серии – это строки матрицы,
Точки – колонки матрицы,
Значения – значения ячейки матрицы на пересечении строки и колонки.
E_Migachev
21.09.2010 16:52Ответ № 7
Используй например этот пример:
Код 1C v 8.х
 Диаграмма = ЭлементыФормы.Диаграмма; 

// Очистить диаграмму, возможно ранее в нее уже выводились данные.
Диаграмма.КоличествоСерий = 0;
Диаграмма.КоличествоТочек = 0;

// Количество серий будет ограничиваться (не все значения будут показываться).
Диаграмма.МаксимумСерий = МаксимумСерий.Ограничено;
Диаграмма.МаксимумСерийКоличество = 7;
Диаграмма.ВидПодписей = ВидПодписейКДиаграмме.Процент;
Диаграмма.ОбластьЗаголовка.Текст = "Обороты номенклатуры";

Запрос = Новый Запрос; Запрос.Текст = "ВЫБРАТЬ
| ПродажиКомпанииОбороты.Номенклатура,
| СУММА(ПродажиКомпанииОбороты.КоличествоОборот) КАК КоличествоОборот
|ИЗ
| РегистрНакопления.Продажи.Обороты(, , , ) КАК ПродажиКомпанииОбороты
|СГРУППИРОВАТЬ ПО
| ПродажиКомпанииОбороты.Номенклатура";

Результат = Запрос.Выполнить();

// Запретить обновление диаграммы на время вывода данных.
Диаграмма.Обновление = Ложь;

// Установить единственную точку.
Диаграмма.КоличествоТочек = 1;
Диаграмма.Точки[0].Текст = "Количество";
Выборка = Результат.Выбрать();

Пока Выборка.Следующий() Цикл

// Количество серий, если бы не ограничивали зависело бы от результата запроса.
КоличествоСерий = Диаграмма.Серии.Количество();
Диаграмма.КоличествоСерий = КоличествоСерий + 1;
Диаграмма.Серии[КоличествоСерий].Текст = Выборка.Номенклатура;

// Установить значение "на пересечении" точки и серии.
// Первый параметр - 0 , так как в диаграмме только одна точка.
Диаграмма.УстановитьЗначение(0, КоличествоСерий, Выборка.КоличествоОборот);

КонецЦикла;

// Обновить диаграмму.
Диаграмма.Обновление = Истина;
SOBOLEV
22.09.2010 10:29Ответ № 8
Процедура КнопкаСформироватьНажатие(Кнопка)
// Вставить содержимое обработчика.
Запрос = Новый Запрос("ВЫБРАТЬ
| Студенты.Наименование,
| Студенты.ЗачислениеГруппа
|ИЗ
| Справочник.Студенты КАК Студенты");
Диаграмма = ЭлементыФормы.Диаграмма2;
Диаграмма.ОбластьЗаголовка.Текст = "Студенты и группы";
Диаграмма.ИсточникДанных = Запрос.Выполнить();

Диаграмма.Серии.Добавить("Студенты");
//Диаграмма.Серии.Добавить("Группа");
//Диаграмма.Точки.Добавить("Студенты");
//Диаграмма.Ресурсы.Добавить("Студенты");

КонецПроцедуры
вот мой запрос я бы хотел чтобы Сондой стороны выводились студенты с другой группы а в середине количество студентов зачисленной в ту или иную группу в данный мамонт появляются Толька студенты по цветам чтобы можно было изменить??
E_Migachev
22.09.2010 10:48Ответ № 9
Цитата
я бы хотел чтобы С ондой стороны выводились студенты с другой группы а в середине количество студентов зачисленной в ту или иную группу

так вывести невозможно!
Можно вывести например Группу и колисчетво студентов в ней, тогда тебе нужно добавить в запрос Итоги, где Итог по ЗачислениеГруппа и ниже Количество(Студенты.Наименование)
SOBOLEV
22.09.2010 11:41Ответ № 10
получается мне нужно написать запрос который посчитает количество студентов в группах можно пример такого запроса+)?
E_Migachev
22.09.2010 12:07Ответ № 11
(10) да *13
возьми вот этот свой запрос:
Код 1C v 8.х
 Запрос = Новый Запрос("ВЫБРАТЬ
| Студенты.Наименование,
| Студенты.ЗачислениеГруппа
|ИЗ
| Справочник.Студенты КАК Студенты");

Открой через конструктор запросов и на закладке Итоги добавь Итог по ЗачислениеГруппа и ниже Студенты.Наименование - Количество
SOBOLEV
22.09.2010 14:08Ответ № 12
Процедура КнопкаСформироватьНажатие(Кнопка)
// Вставить содержимое обработчика.
Запрос = Новый Запрос("ВЫБРАТЬ
| Студенты.ЗачислениеГруппа КАК ЗачислениеГруппа,
| Студенты.Наименование
|ИЗ
| Справочник.Студенты КАК Студенты

|СГРУППИРОВАТЬ ПО
| Студенты.ЗачислениеГруппа,
| Студенты.Наименование
|ИТОГИ ПО
| ЗачислениеГруппа,
| Студенты.Наименование");
Диаграмма = ЭлементыФормы.Диаграмма2;
Диаграмма.ОбластьЗаголовка.Текст = "Студенты и группы";
Диаграмма.ИсточникДанных = Запрос.Выполнить();

Диаграмма.Серии.Добавить("Студенты");
Диаграмма.Точки.Добавить("АИС-07");
Диаграмма.Точки.Добавить("АИС-08");
теперь в запросе показывает группу и сколька в ней студентов что делать дальше+)
SOBOLEV
22.09.2010 14:13Ответ № 13
на икране поевляет я диаграмма с права группы разных цветов а с низу три точки больших чёрных поперёк раскрашеные линиями с разными цветами и подписаны группы +))
E_Migachev
22.09.2010 14:27Ответ № 14
(12) Выделяй код, так удобнее читать
(13) поменяй вид диаграммы для лушего отображения, выбери со столбиками например
SOBOLEV
22.09.2010 14:43Ответ № 15
поменял +) у меня с боку диаграммы идут цифры от нуля до 0.9 как их можно поменять у меня видимо из за это го не работает!
E_Migachev
22.09.2010 14:53Ответ № 16
А посмотри результат выполнения запроса, так какие количества стоят?
В свойствах диаграммы проверь МаксимумСерий, да и вообще настройки серий посмотри
SOBOLEV
22.09.2010 15:16Ответ № 17
Максимум серий не заданно может у меня всётаки в запросе вилки у меня при работе запроса виден номер группы и подним паля студентов которые в ней учатся но негде не видно число что допустим 5 студентов в этой и тд.
E_Migachev
22.09.2010 16:51Ответ № 18
(17) *12 немного не так я тебе сказал, нужна закладка не ИТОГИ и ГРУППИРОВКА и код примерно будет такой:
Код 1C v 8.х
 Запрос = Новый Запрос("ВЫБРАТЬ
| Студенты.ЗачислениеГруппа КАК Группа,
| Количество(Студенты.Наименование) КАК Количество
|ИЗ
| Справочник.Студенты КАК Студенты
|СГРУППИРОВАТЬ ПО
| Студенты.ЗачислениеГруппа");
SOBOLEV
23.09.2010 09:43Ответ № 19
спасибо большое всё получилось график выводит сейчас буду разберется коде и что я сделал не правильно))) поэтому вопрос пока не закрою)
E_Migachev
23.09.2010 09:50Ответ № 20
(19) По завершении выложи весь код достроения графика )
SOBOLEV
23.09.2010 10:36Ответ № 21
спасибо
SOBOLEV
23.09.2010 10:37Ответ № 22
Код 1C v 8.х
 
Процедура КнопкаСформироватьНажатие(Кнопка)
// Вставить содержимое обработчика.

Запрос = Новый Запрос("ВЫБРАТЬ
| Студенты.ЗачислениеГруппа КАК Группа,
| Количество(Студенты.Наименование) КАК Количество
|ИЗ
| Справочник.Студенты КАК Студенты
|СГРУППИРОВАТЬ ПО
| Студенты.ЗачислениеГруппа");
Диаграмма = ЭлементыФормы.Диаграмма2;
Диаграмма.ОбластьЗаголовка.Текст = "Студенты и группы";
Диаграмма.ИсточникДанных = Запрос.Выполнить();

КонецПроцедуры
SOBOLEV
23.09.2010 10:38Ответ № 23
Вопрос закрыт!
Подсказка: Для выделения Кода используйте (в редакторе).
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.