helpf.pro
Регистрация

v8.2 УП: Разрыв страницы

Kamil
22.09.2013 16:23Прочитано: 2563
Как по областям сделать разрыв страниц??? Срочно
Yandex
Возможно, вас также заинтересует
Реклама на портале
Kamil
22.09.2013 16:58Ответ № 1
Вопрос закрыт!
E_Migachev
22.09.2013 23:17Ответ № 2
ВывестиГоризонтальныйРазделительСтраниц
ВывестиВертикальныйРазделительСтраниц

Код 1C v 8.х
 ОбластьПодписи = Макет.ПолучитьОбласть("ОбластьПодписи");
ОбластьПодписи.Параметры.Заполнить(Данные);

КолвоСтрок = МногострочнаяТаблица.Количество();
НомерСтроки = 1;
Для Каждого Стр Из МногострочнаяТаблица Цикл
СтрокаВывода = Макет.ПолучитьОбласть("СтрокаОбластиЗатрат");
СтрокаВывода.Параметры.Заполнить(Данные);
МассивОбластей = Новый Массив;
МассивОбластей.Добавить(СтрокаВывода);
Если НомерСтроки = КолвоСтрок Тогда
МассивОбластей.Добавить(ОбластьПодписи);
КонецЕсли;
Если Не ТабличныйДокумент.ПроверитьВывод(МассивОбластей) Тогда
ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц()
КонецЕсли;
ТабличныйДокумент.Вывести(СтрокаВывода);
НомерСтроки = НомерСтроки + 1;
КонецЦикла;
ТабличныйДокумент.Вывести(ОбластьПодписи);
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.