helpf.pro
Регистрация

v8: Таблица значений Параметр процедуры

Bell
23.09.2013 13:43Прочитано: 790
Здравствуйте
Как передать ТаблицуЗначений (ТЗ) из общего модуля в модуль объекта документа для дальнейшей обработки

ОБЩИЙ МОДУЛЬ

Код 1C v 8.х
 Процедура ААА(ДокументОбъект, ТЗ) Экспорт

// Сам запрос

ТЗ = Запрос.Выполнить().Выгрузить();

КонецПроцедуры



МОДУЛЬ ОБЪЕКТА ДОКУМЕНТА

Код 1C v 8.х
 ОбработкаПроведения(Отказ, Режим)

МойОбщийМодуль.ААА(ЭтотОбъект, ??????);

КонецПроцедуры

Изменено 23.09.13 13:43:51
Yandex
Возможно, вас также заинтересует
Реклама на портале
Sekator
23.09.2013 14:43Ответ № 1
Код 1C v 8.х
 
// общий модуль
Функция ААА()

ТЗ = Запрос.Выполнить().Выгрузить();

Возврат ТЗ;

КонецФункции;

// модуль документа
Процедура ОбработкаПроведения(Отказ, Режим)

ТЗ = МойОбщийМодуль.ААА();

КонецПроцедуры

Изменено 23.09.13 14:44:14
Bell
23.09.2013 16:49Ответ № 2
У меня процедура, а не функция. Надо именно через процедуру
Sekator
23.09.2013 18:17Ответ № 3
А зачем именно через процедуру? Все, что можно сделать процедурой, можно сделать и функцией, но не наоборот )
Sekator
23.09.2013 18:19Ответ № 4
Просто если через процедуру, то придется в общем модуле еще и переменную ТЗ объявлять... А оно надо?

Код 1C v 8.х
 
// общий модуль
Перем ТЗ Экспорт;
Bell
23.09.2013 19:11Ответ № 5
С Перем ТЗ Экспорт (Модуль объекта документа) Все пошло, но я тоже сторонник ничего лишенго не ставить Хотелось бы уйти от его.
А как тогда сделать разумно?

ОБЩИЙ МОДУЛЬ


// Процедуру делаю универсальной на все проверки и сравнения при проведении документа все получиль(работает), но с ТЗ (дополнительно) не могу совладать.
// Параметры все не указываю их больще
Код 1C v 8.х
 Процедура ААА(ДокументОбъект, ТЗ) Экспорт

// Сам запрос .....
// Получаю результат
Результат = Запрос.Выполнить().Выбрать();
// Обхожу результат
Пока Результат.Следующий() Цикл


// Здесь проверяю отрицатеьные остатки
// Делаю различные сравннения и может чего еще понадобится
// ВЫвожу комментарии в отдельное окно

КонецЦикла;

// Раз у меня уже ВСЕ (с учетом различных соединений) есть в результате запросе, то что бы не делать
// еще один (процедура или функции) выгружаю в ТаблицуЗначения и экспортию ее в модуль объекта документа
ТЗ = Запрос.Выполнить().Выгрузить();

КонецПроцедуры


// МОДУЛЬ ОБЪЕКТА ДОКУМЕНТА

Код 1C v 8.х
 Процедура ОбработкаПроведения(Отказ, Режим)

// Получаю параметры для дальнейшей обработки
МойМодуль.ААА(ЭтотОбъект, ???? ;
// ТЗ придется сворачивать по различным условиям и т.д.

КонецПроцедуры

Изменено 23.09.13 19:23:56
Bell
25.09.2013 13:54Ответ № 6
Вопрос закрыт!
Подсказка: Для редактирования своего ответа щелкните по значку (справа)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.