helpf.pro
Регистрация

v8: Макеты и справочники

Borisga
08.10.2013 12:30Прочитано: 3886
Здравствуйте у меня такой вопрос мне нужно вытащить из макета табличное значение En и вставить его в УправляемуюФормуСписка в табличную часть в столбец En высылаю часть кода...

&НаСервереБезКонтекста
Процедура ЗаполнитьEn()

Макет = Справочники.<Имя>.ПолучитьМакет("Макет");
//Макет = ПолучитьМакет("Макет");
//ТекущаяОбласть = Макет.ПолучитьОбласть("Строка|Колонка");

НачальнаяКолонка = 1;
НачальнаяСтрока = 2;

Пока 1=1 Цикл

ТекущаяОбласть = Макет.ПолучитьОбласть("R" + НачальнаяСтрока + "C" + НачальнаяКолонка);

Если ЗначениеЗаполнено(ТекущаяОбласть.ТекущаяОбласть.Текст) Тогда

ЗначениеВЯчейке = ТекущаяОбласть.ТекущаяОбласть.Текст;

//1.
Ссылка = Справочники.<Имя>.БарботажныйБакКомпенсатораДавления;

Имя = "БарботажныйБакКомпенсатораДавления";

Справочники.<Имя>[Имя]

//1 получить ссылку справочника по внутр имени
//2 получить анг значение
//3 получить объект справочника
//4 записать в него анг яз

Иначе
Прервать;

КонецЕсли;

НачальнаяСтрока = НачальнаяСтрока + 1;

КонецЦикла;



КонецПроцедуры

Помогите пожалуйста только учусь еще)
Yandex
Возможно, вас также заинтересует
Реклама на портале
DJ_Serega
09.10.2013 23:45Ответ № 1
//1 получить ссылку справочника по внутр имени
что значит ссылку справочника по внутр имени?
Подсказка: Вы можете добавить любую страничку в Избранное щелкнув по значку
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.