helpf.pro
Регистрация

v8: Разрешить иметь значение ноль.

Novoross
14.10.2013 11:25Прочитано: 2466
Табличная часть в форме документа. Стоимость услуги может быть = 0.00. Однако при попытке оставить там нулевое значение выдается ошибка - Не заполнена колонка "Стоимость услуги". Подскажите - как разрешить иметь нулевое значение?Процедура УслугиКолличествоУслугПриИзменении(Элемент)
СтрокаТабличнойЧасти = Элементы.Услуги.ТекущиеДанные;
СтрокаТабличнойЧасти.ВсегоПоУслуге = СтрокаТабличнойЧасти.КолличествоУслуг * СтрокаТабличнойЧасти.СтоимостьУслуги + СтрокаТабличнойЧасти.СтоимостьИсполнителя;
КонецПроцедуры

&НаКлиенте
Процедура УслугиСтоимостьУслугиПриИзменении(Элемент)
СтрокаТабличнойЧасти = Элементы.Услуги.ТекущиеДанные;
СтрокаТабличнойЧасти.ВсегоПоУслуге = СтрокаТабличнойЧасти.КолличествоУслуг * СтрокаТабличнойЧасти.СтоимостьУслуги + СтрокаТабличнойЧасти.СтоимостьИсполнителя;
СтрокаТабличнойЧасти.СтоимостьУслуги = СтрокаТабличнойЧасти.КолличествоУслуг * СтрокаТабличнойЧасти.СтоимостьУслуги;
КонецПроцедуры

&НаКлиенте
Процедура УслугиСтоимостьИсполнителяПриИзменении(Элемент)
СтрокаТабличнойЧасти = Элементы.Услуги.ТекущиеДанные;
СтрокаТабличнойЧасти.ВсегоПоУслуге = СтрокаТабличнойЧасти.КолличествоУслуг * СтрокаТабличнойЧасти.СтоимостьУслуги + СтрокаТабличнойЧасти.СтоимостьИсполнителя;
КонецПроцедуры
[/c8]
Yandex
Возможно, вас также заинтересует
Реклама на портале
Jonsony
14.10.2013 12:33Ответ № 1
(0) Novoross, отключить проверку заполнения поля в конфигураторе
Подсказка: Для быстрого поиска ответов - используйте 'Поиск'
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.