helpf.pro
Регистрация

v8: Как выйти из Пока 1=1 Цикл (Бесконечного цикла)

Borisga
15.10.2013 18:00Прочитано: 11964
Как выйти из Пока 1=1 Цикл (Бесконечного цикла)
Если возможно подскажите как можно прервать такой цикл
При условии что в табличном части если пустая строка
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
15.10.2013 18:57Ответ № 1
Оператор
Код 1C v 8.х
  Прервать;   
alex-skrip
16.10.2013 10:31Ответ № 2
Флаг=0;
Пока Флаг=0 Цикл
Если ПустаяСтрока(Поле)=Истина Тогда
Флаг=1;
КонецЕсли;
КонецЦикла;
Jonsony
16.10.2013 12:17Ответ № 3
(2) alex-skrip,
вернее
Код 1C v 8.2 УП
 
Пока 1=1 Цикл
Если Не ЗначениеЗаполнено(СтрокаТовар.Товар) Тогда
Прервать;
Иначе
КонецЕсли;
КонецЦикла;


я обычно такие штуки в одну строку пишу
Код 1C v 8.2 УП
 
Если Не ЗначениеЗаполнено(СтрокаТовар.Товар) Тогда Прервать; КонецЕсли;

Изменено 16.10.13 12:18:55
Подсказка: Вы получили ответ на свой вопрос - закройте вопрос!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.