helpf.pro
Регистрация

v8: Почему не выводит картинку?

Ermak
28.10.2013 14:55Прочитано: 3666
Подскажите в чем дело, почему за место картинки выводит текст ХранилищеЗначения

Код 1C v 8.х
 Процедура КнопкаВыполнитьНажатие(Кнопка)

ТабДокумент = Новый ТабличныйДокумент;
Макет = ЭтотОбъект.ПолучитьМакет("Макет");
ОбластьМакета = Макет.ПолучитьОбласть("Шапка");
ТабДокумент.Вывести(ОбластьМакета);
ОбластьМакета = Макет.ПолучитьОбласть("Строка");

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Номенклатура.Наименование,
| Номенклатура.Артикул,
| Номенклатура.ОсновноеИзображение.Хранилище КАК Хранилище
|ИЗ
| Справочник.Номенклатура КАК Номенклатура";


Выборка = Запрос.Выполнить().Выбрать();
номер=0;
Пока Выборка.Следующий() цикл
номер=номер+1;
ОбластьМакета.Параметры.номер = номер;
//вставляем рисунок

Рис=Макет.Рисунки.D1;
Если ЗначениеЗаполнено(Выборка.Хранилище) Тогда
Дан=Выборка.Хранилище.Получить();
Рис.Картинка=Новый Картинка(Дан.ПолучитьДвоичныеДанные());;
Рис.РазмерКартинки = РазмерКартинки.АвтоРазмер;
Рис.Верх = 5;
Рис.Высота = 10;
Рис.Ширина = 10;
Рис.Лево = 5;
КонецЕсли;


ОбластьМакета.Параметры.IMG = Выборка.Хранилище;
ОбластьМакета.Параметры.Артикул = Выборка.Артикул;
ОбластьМакета.Параметры.Наименование = Выборка.Наименование;
ТабДокумент.Вывести(ОбластьМакета);
КонецЦикла;

ТабДокумент.ОтображатьСетку = Ложь;
ТабДокумент.ТолькоПросмотр = Ложь;
ТабДокумент.ОтображатьЗаголовки = Ложь;
//ТабДокумент.Показать();
ТабДокумент.ОтображатьГруппировки=Истина;
ТабДокумент.КоличествоЭкземпляров = 4;
ТабДокумент.Записать("D:\1C\1.xls",ТипФайлаТабличногоДокумента.XLS);

КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
28.10.2013 21:00Ответ № 1
а если просто
Код 1C v 8.х
  Рис.Картинка=Дан;   

Вообще про вывод: Вывод картинки (изображения) на печать, в макет (табличный документ)
Подсказка: Вы можете приложить к ответу файл или изображение щелкнув по значку или в редакторе.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.