helpf.pro
Регистрация

v8: ОбновитьТЧ

Kamil
05.11.2013 14:59Прочитано: 1889
Добрый день! В форме документа я установил кнопку где меняется все счета номенклатуры.... но пока не пере открыть документ... Счета будут показывать старые... как обновить строки ТЧ.... Спасибо заранее!!!
Yandex
Возможно, вас также заинтересует
Реклама на портале
DJ_Serega
05.11.2013 22:59Ответ № 1
Код 1C v 8.х
 ЭлементыФормы.ТабличнаяЧасть1.ОбновитьСтроки();   


Код
ТабличноеПоле (TableBox)
ОбновитьСтроки (RefreshRows)
Вариант синтаксиса: Обновить все

Синтаксис:

ОбновитьСтроки()
Описание варианта метода:

Выполняет обновление всех видимых строк табличного поля.
Вариант синтаксиса: По строке или массиву строк

Синтаксис:

ОбновитьСтроки(<Строка, МассивСтрок>)
Параметры:

<Строка, МассивСтрок> (необязательный)

Тип: Строка табличного поля; Массив.
Строка или массив строк табличного поля.
Описание варианта метода:

Выполняет обновление указанной строки или группы строк табличного поля.
Описание:

Обновляет табличное поле.
Если параметр не указан, то выполняется обновление всех строк.
Если указана строка табличного поля, то обновляется именно указанная строка.
Если указан массив строк, то обновляются указанные в массиве строки.

Доступность:

Толстый клиент.
Kamil
06.11.2013 09:01Ответ № 2
Выходить ошибка.... Может я не правильно делаю.... Вот мой код... Прошу помочь... Спасибо заранее
ДокОбъект = ЭтотОбъект;
Если ДокОбъект.Аналоги.Количество()> 0 Тогда
Для каждого Стр Из ДокОбъект.Аналоги Цикл
Счет1310 = ПланыСчетов.Типовой.НайтиПоКоду("1310");
Счет1351 = ПланыСчетов.Налоговый.НайтиПоКоду("1351");
Стр.СчетБУ = Счет1310;
Стр.СчетНУ = Счет1351;
КонецЦикла;
КонецЕсли;
Если ДокОбъект.Ингредиенты.Количество()> 0 Тогда
Для каждого Стр Из ДокОбъект.Ингредиенты Цикл
Счет1310 = ПланыСчетов.Типовой.НайтиПоКоду("1310");
Счет1351 = ПланыСчетов.Налоговый.НайтиПоКоду("1351");
Стр.СчетБУ = Счет1310;
Стр.СчетНУ = Счет1351;
КонецЦикла;
КонецЕсли;
ДокОбъект.Записать();
Изменено 06.11.13 09:46:22
Kamil
06.11.2013 09:23Ответ № 3
Мне нужно обновить строки динамический...
Kamil
06.11.2013 11:28Ответ № 4
Проблема была в другом.... Все разобрались))
Подсказка:Вы можете добавить любую страничку в Социальные закладки щелкнув по значку соцсетей (в вверху)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.