helpf.pro
Регистрация

v8: Отчет по ролям

wer19812
06.11.2013 15:55Прочитано: 13593
Добрый день. Помогите пож-та. Нужно написать отчет из трех колонок: Пользователь | Объект доступа( виды документов) | роль.

Написал
:
Код 1C v 8.2 УП
 Выборка = ПользователиИнформационнойБазы.ПолучитьПользователей();
Для Каждого ЭлементМассива Из Выборка Цикл
ИмяПользователя = ЭлементМассива.Имя;
ПолноеИмяПользователя = ЭлементМассива.ПолноеИмя;
ЕстьПароль = ЭлементМассива.ПарольУстановлен;

Роли = ЭлементМассива.Роли;
Для Каждого Роль Из Роли Цикл
ИмяРоли = Роль.Имя;
КонецЦикла;
КонецЦикла;

Вытащил пользователя и все присвоенные ему роли. Как сюда добавить документы?
Изменено 06.11.13 16:06:34
Yandex
Возможно, вас также заинтересует
Реклама на портале
Jonsony
06.11.2013 19:10Ответ № 1
а проще нельзя?

Код 1C v 8.2 УП
 
ПользовательИнформационнойБазы (InfoBaseUser)
Свойства:

АутентификацияОС (OSAuthentication)
АутентификацияСтандартная (StandardAuthentication)
ЗапрещеноИзменятьПароль (CannotChangePassword)
Имя (Name)
ОсновнойИнтерфейс (DefaultInterface)
Пароль (Password)
ПарольУстановлен (PasswordIsSet)
ПоказыватьВСпискеВыбора (ShowInList)
ПолноеИмя (FullName)
ПользовательОС (OSUser)
РазделениеДанных (DataSeparation)
РежимЗапуска (RunMode)
Роли (Roles)
СохраняемоеЗначениеПароля (StoredPasswordValue)
УникальныйИдентификатор (UUID)
Язык (Language)

Методы:

Записать (Write)
Удалить (Delete)

Описание:

Предназначен для получения и записи сведений о пользователе в информационную базу.
Если текущий пользователь не обладает административными правами, он может изменить только ограниченный набор сведений (свойства объекта) о себе (ПолноеИмя, Язык, Пароль). При изменении этих свойств остальные свойства сохраняют свои значения.

Доступность:

Сервер, толстый клиент, внешнее соединение.
Возможен обмен с сервером.
wer19812
07.11.2013 09:17Ответ № 2
Добрый день, не совсем то. Скажу по другому, нужна расшифровка к ролям, какие ик доступны документы, для "Чтения", "Редактирования","Просмотра","Удаления". Прочие метаданные как то "справочники", "Отчеты" и тд. Не нужны.
Gonzik2
07.11.2013 18:28Ответ № 3
Попробуй так:
Код 1C v 8.2 УП
     Выборка = ПользователиИнформационнойБазы.ПолучитьПользователей();
Для Каждого ЭлементМассива Из Выборка Цикл
ИмяПользователя = ЭлементМассива.Имя;
ПолноеИмяПользователя = ЭлементМассива.ПолноеИмя;
ЕстьПароль = ЭлементМассива.ПарольУстановлен;

Роли = ЭлементМассива.Роли;
Для Каждого Роль Из Роли Цикл
ИмяРоли = Роль.Имя;
Для Каждого Документ Из Метаданные.Документы Цикл
ЕстьДоступЧтение = ПравоДоступа("Чтение", Документ, Роль);
ЕстьДоступИзменение = ПравоДоступа("Изменение", Документ, Роль);
... и т. д.
КонецЦикла;

КонецЦикла;
КонецЦикла;
Подсказка: Для быстрого поиска ответов - используйте 'Поиск'
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.