helpf.pro
Регистрация

v8: Таблица значений

Bell
13.01.2014 11:08Прочитано: 703
Здравствуйте
Имею запрос
Как результат запроса передать в ТаблицуЗначений общейформы, что бы были видны наименования колонок и Значения строк?
В результате запроса ( Результат они все есть.Пробовал разными способами всегда есть проблемы.
Показывает почти всегда 1 колонку (Колонка1 или значение), хотя в Результате есть все колонки которые мне нужны.


/
Код 1C v 8.х
 // Мой запрос
Результат = Запрос.Выполнить().Выгрузить(); // в результате все есть (Колонки, например, наименовани и АдресЭлектроннойПочты;).

ФТЗ = ПолучитьОбщуюФорму("ФормаТаблицаЗначений");

//В таблице значений должны появиться Колонки наименование и АдресЭлектроннойПочты;
// Строки пустые
//ФТЗ.ТаблицаЗначений = Результат.Скопировать(); // ???????

СтрокаТЗ = ФТЗ.ОткрытьМодально();

// При выборе строки (Хотя строка пустая) все подставляется как надо из общей формы в форму документа
Если СтрокаТЗ <> Неопределено Тогда
ЭлементыФормы.От.Значение = СтрокаТЗ.АдресЭлектроннойПочты;
иначе
Возврат;
КонецЕсли
;
Изменено 13.01.14 11:26:12
Yandex
Возможно, вас также заинтересует
Реклама на портале
Gonzik2
13.01.2014 11:39Ответ № 1
Код 1C v 8.х
 ФТЗ.ТаблицаЗначений = Результат;
ФТЗ.ЭлементыФормы.ТаблицаЗначений.СоздатьКолонки();
Bell
13.01.2014 12:15Ответ № 2
Получилось !!!
Вот сразу возник вопрос.
А ширину колонок созданных как отрегулировать, что бы красиво было. ?
Gonzik2
13.01.2014 12:35Ответ № 3
ФТЗ.ЭлементыФормы.ТаблицаЗначений.Колонки.НужнаяКолонка.Ширина
Bell
13.01.2014 12:49Ответ № 4
Спасибо
Тоже решил через цикл применительно к таблице РЕЗУЛЬТАТ,

Код 1C v 8.х
  Для Каждого Колон Из Результат.Колонки Цикл
ИмяКолонки = Колон.Имя;
Если ИмяКолонки = "АдресЭлектроннойПочты" Тогда
Колон.Ширина = "10";
КонецЕсли;

КонецЦикла;
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.