helpf.pro
Регистрация

v8.2 УП: 1С не могу удалить документ программно Выдает ошибку

ali
31.01.2014 14:20Прочитано: 4663
МодульФормы обработки
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
Пока Выборка.Следующий() Цикл
ОбъектДок = Выборка.Ссылка.ПолучитьОбъект();
ОбъектДок.Удалить(); {(1)}: Обращение к процедуре объекта как к функции (Удалить)

КонецЦикла;
Yandex
Возможно, вас также заинтересует
Реклама на портале
Jonsony
31.01.2014 15:31Ответ № 1
(0) ali, а может всё же так?
Код 1C v 8.2 УП
 
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
Пока Выборка.Следующий() Цикл
ОбъектДок = Выборка.ПолучитьОбъект();
ОбъектДок.Удалить();

КонецЦикла;

Изменено 31.01.14 16:03:48
ali
31.01.2014 15:49Ответ № 2
(1) Jonsony, Да так выдает обшибку
Код 1C v 8.х
 {(1)}: Обращение к процедуре объекта как к функции (Удалить)	

Изменено 31.01.14 15:50:37
Jonsony
31.01.2014 16:08Ответ № 3
вообще по логике это не из запроса надо делать, а чисто через отбор с условиями
Jonsony
31.01.2014 16:13Ответ № 4
делал аналогичное, только со справочником номенклатуры
менял на верхний регистр у определённой группы наименование для печати
но так же можно было и на удаление помечать
Код 1C v 8.2 УП
 
&НаКлиенте
Процедура Обработать(Команда)
// Вставить содержимое обработчика.
ОбработатьДанные(ГруппаТовара);
КонецПроцедуры

&НаСервереБезКонтекста
Процедура ОбработатьДанные(Старший)
// Выбрать(<Родитель>, <Владелец>, <Отбор>, <Порядок>)
Номенклатура = Справочники.Номенклатура;
Выборка = Номенклатура.Выбрать(Старший,,,);
Пока Выборка.Следующий() Цикл
Объект = Выборка.ПолучитьОбъект();
Объект.НаименованиеПолное = ВРег(Объект.НаименованиеПолное);
Попытка
Объект.Записать();
Исключение

КонецПопытки;
КонецЦикла;

КонецПроцедуры

"ГруппаТовара" = реквизит на форме для выбора родителя
ali
31.01.2014 17:03Ответ № 5
Да Спасибо
получил выборку через объектную модель и все удалил
Подсказка:Вы можете добавить любую страничку в Социальные закладки щелкнув по значку соцсетей (в вверху)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.