helpf.pro
Регистрация

v8: Массив в ТаблицуЗначений

Bell
07.03.2014 12:58Прочитано: 795
Здравствуйте
Имею общую форму ФормаТаблицаЗначений, на ней есть ТаблицаЗначений (без колонок)
Имею запрос его результат загружаю в массив. (НеСервере)
Вопросы
1 Как результат запроса (он в массиве ) выгрузить в в ТаблицаЗначений на общей форме и создать колонки(НаКлиенте)
2. Если возможность результат запроса выгрузить в ТаблицуЗначений (НаСервере) и передать ее в общую форму (НаКлиенте)


&НаСервере
Код 1C v 8.х
 Функция ААА()

Мой запрос
......
//Результат = Запрос.Выполнить().Выгрузить();
Выборка = Запрос.Выполнить().Выбрать();

СтруктураВозврата = Новый Структура;
МассивВозврата = Новый Массив;

Пока Выборка.Следующий() Цикл

СтруктураВозврата.Вставить("Наименование", Выборка.Наименование);
СтруктураВозврата.Вставить("Владелец", Выборка.Владелец);
СтруктураВозврата.Вставить("Валюта", Выборка.Валюта);
СтруктураВозврата.Вставить("ДатаС", Выборка.ДатаС);
СтруктураВозврата.Вставить("ДатаПо", Выборка.ДатаПо);

МассивВозврата.Добавить(СтруктураВозврата);

КонецЦикла;

//Возврат СтруктураВозврата;
Возврат МассивВозврата;
//Возврат Результат;

КонецФункции


Код 1C v 8.х
 &НаКлиенте
Процедура ПодборТЧ_Договоры(Команда)

КонтрагентДоговоры = ААА(); // Массив ????

ФТЗ = ПолучитьФорму("ОбщаяФорма.ФормаТаблицаЗначений");
ФТЗ.Заголовок = "Выберите договор организации.";



ФТЗ.Открыть();


КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
Mokey
11.03.2014 11:18Ответ № 1

Изменено 11.03.14 11:19:56
Bell
11.03.2014 13:17Ответ № 2
Я уже сделал преобразования массива в таблицузначений
Теперь осталось вернуть данные из общей формы на форму документа

Код 1C v 8.х
 &НаКлиенте
Процедура ССС(Команда)

Массив= ЗаполнитьДанные();

ОбщаяФорма = ПолучитьФорму("ОбщаяФорма.ФормаТаблицаЗначений");

Для каждого СтрокаМассива Из Массив Цикл

НВС = ОбщаяФорма.ТаблицаЗначений.Добавить();
ЗаполнитьЗначенияСвойств(НВС, СтрокаМассива);
НВС.Наименование = СтрокаМассива.Ссылка;

КонецЦикла;

// 7?????????
// Вот как отсюда делать
ОбщаяФорма.Открыть();

Надо сделать параметр
// ошибка обращение к процедура как к функции
ВыбраннаяСтрока = ОбщаяФорма.Открыть();


КонецПроцедуры

Изменено 11.03.14 13:19:09
Hallon
11.03.2014 14:20Ответ № 3
Код 1C v 8.2 УП
 ВыбраннаяСтрока = ОбщаяФорма.ОткрытьМодально();  //Так сделай   
Bell
12.03.2014 09:30Ответ № 4
Так пробовалось уже. Это УФ (сделал Блокировать окно владельца). Тут загвоздка с клиент сервер.
Что то уже получается (пробую через общей модуль делать или функция или процедуру открытия), чуть возже отпишусь Открыть форму не проблема . зацепку сделать для возврат данных из таблицызначений общей формы воз что не идет никак..

//ВыбраннаяСтрока = ФТЗ.ОткрытьМодельно();

{Документ.ПлатежноеПоручениеИП.Форма.ФормаДокумента.Форма(64)}: Метод объекта не обнаружен (ОткрытьМодельно)
ВыбраннаяСтрока = ОбщаяФорма.ОткрытьМодельно();
Изменено 12.03.14 09:35:05
Mokey
12.03.2014 09:59Ответ № 5
ОткрытьМодельно() такого метода и нет, есть ОткрытьМодально()
Bell
12.03.2014 12:51Ответ № 6
(5) СПАСИБО, а то совсем ослеп явной граматичиской ошибки не вижу .

Если кому будет интересно долше все просто

В
Код 1C v 8.х
 ыбраннаяСтрока =  ФТЗ.ОткрытьМодально();

Если ВыбраннаяСтрока <> Неопределено Тогда

НС = Объект.Договоры.Добавить();
НС.Наименование = ВыбраннаяСтрока.Наименование;
// и т.д.
иначе
Возврат;
КонецЕсли;
Подсказка: Вы можете приложить к ответу файл или изображение щелкнув по значку или в редакторе.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.