helpf.pro
Регистрация

v8.2 УП: Нужна помощь в выгрузке ТЧ в DBF

Alex_UA
20.03.2014 13:35Прочитано: 2544
Помогите пожалуйста, нужно выгрузить в DBF данные с табличной части документа.
Код 1C v 8.2 УП
 
Процедура КнопкаВыполнитьНажатие(Кнопка)
БД = Новый XBase;
БД.Поля.Добавить("ACCT_CARD","S",10);
БД.Поля.Добавить("FIO","S",50);
БД.Поля.Добавить("ID_CODE","S",10);
БД.Поля.Добавить("SUMA","N",10,2);
БД.СоздатьФайл("C://1.dbf");

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ИНАГРО_ЗарплатаКВыплатеОрганизаций.РаботникиОрганизации.(
| Выплата,
| НомерКарточки,
| Сотрудник,
| Сотрудник.Физлицо.КодПоДРФО
| )
|ИЗ
| Документ.ИНАГРО_ЗарплатаКВыплатеОрганизаций КАК ИНАГРО_ЗарплатаКВыплатеОрганизаций";

Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
БД.Добавить();
БД.ACCT_CARD = Выборка.НомерКарточки;
БД.FIO = Выборка.Сотрудник;
БД.ID_CODE = Выборка.Сотрудник.Физлицо.КодПоДРФО;
БД.SUMA = Выборка.Выплата
КонецЦикла;
БД.ЗакрытьФайл();


КонецПроцедуры

Изменено 20.03.14 13:36:58
Yandex
Возможно, вас также заинтересует
Реклама на портале
Mokey
20.03.2014 13:52Ответ № 1
И.............
Mokey
20.03.2014 13:55Ответ № 2
я подозреваю, что запрос не отработал, или, правильнее будет сказать, не видите результатов его работы. Попробуйте сделать запрос непосредственно к ТЧ документа:
Код 1C v 8.2 УП
 Процедура КнопкаВыполнитьНажатие(Кнопка)
БД = Новый XBase;
БД.Поля.Добавить("ACCT_CARD","S",10);
БД.Поля.Добавить("FIO","S",50);
БД.Поля.Добавить("ID_CODE","S",10);
БД.Поля.Добавить("SUMA","N",10,2);
БД.СоздатьФайл("C://1.dbf");

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ИНАГРО_ЗарплатаКВыплатеОрганизаций.Выплата,
| ИНАГРО_ЗарплатаКВыплатеОрганизаций.НомерКарточки,
| ИНАГРО_ЗарплатаКВыплатеОрганизаций.Сотрудник,
| ИНАГРО_ЗарплатаКВыплатеОрганизаций.Сотрудник.Физлицо.КодПоДРФО КАК КодПоДРФО
| )
|ИЗ
| Документ.ИНАГРО_ЗарплатаКВыплатеОрганизаций.ИмяТЧ КАК ИНАГРО_ЗарплатаКВыплатеОрганизаций";

Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
БД.Добавить();
БД.ACCT_CARD = Выборка.НомерКарточки;
БД.FIO = Выборка.Сотрудник;
БД.ID_CODE = Выборка.КодПоДРФО;
БД.SUMA = Выборка.Выплата
КонецЦикла;
БД.ЗакрытьФайл();


КонецПроцедуры
Alex_UA
20.03.2014 14:38Ответ № 3
(2) Mokey, запрос исправил, если его отрабатываю в консоле запросов даные есть а вот файл дбф получаеться пустой )
Alex_UA
20.03.2014 14:47Ответ № 4
Нашол ошибку нужно было дописать БД.АвтоСохранение = Истина;

Всем спасибо !
Подсказка: Вы получили ответ на свой вопрос - закройте вопрос!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.