helpf.pro
Регистрация

v8.2 УП: Помогите с временным хранилищем

fox_haus
21.04.2014 12:14Прочитано: 2775
Пишу код такой
&НаКлиенте
Процедура Команда1(Команда)
Команда1НаСервере();

МассивДанных = ПолучитьИзВременногоХранилища(Адресс);
Сообщить("нн" );
КонецПроцедуры

&НаСервере
Процедура Команда1НаСервере() экспорт
Массив=Новый Массив;
Массив.Добавить("Добавили строку");
Адресс= ПоместитьВоВременноеХранилище (Массив,Новый УникальныйИдентификатор);

КонецПроцедуры

Не могу понять почему идет сообщение типа Адресс неопределенный?
Подскажите как сделать правильно
Yandex
Возможно, вас также заинтересует
Реклама на портале
Rustavelli
22.04.2014 11:46Ответ № 1
Может адресс нужно как переменную модуля сделать
Hallon
23.04.2014 17:12Ответ № 2
Если у вас управляемые формы, то скорей всего ошибка из-за того что для начала вам нужно получить эту переменную Адресс с сервера на клиент где эта переменная и нужна.

&НаСервере
Функция Команда1НаСервере() экспорт
Массив=Новый Массив;
Массив.Добавить("Добавили строку");
Адресс= ПоместитьВоВременноеХранилище (Массив,Новый УникальныйИдентификатор);

Возврат Адресс;

КонецФункции

Вызывайте функцию на клиенте чтобы получить переменную и думаю все будет ОК.
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.