helpf.pro
Регистрация

v8.2 УП: Посчитать количество строк в табличном поле.

Krolik13
17.06.2014 12:09Прочитано: 2280

Добрый день, есть табличное поле которое заполняется из запроса, необходимо посчитать количество строк за минусом определенных строк.

Код 1C v 8.х
 

процедура счетстрок ()
КолСтр = 0;
КолСтр = КолСтр + ВсеФизЛица.Количество();
ПолеСписка1.Добавить(КолСтр)
конецпроцедуры

Вот сам текст запроса, может в запросе посчитать ? 

Код 1C v 8.х
 

Запрос = Новый Запрос;
Запрос.Текст = 
"ВЫБРАТЬ
| СоставБригадыСрезПоследних.Сотрудники КАК ФизЛицо,
| СоставБригадыСрезПоследних.Бригада КАК Бригада,
| СоставБригадыСрезПоследних.Сотрудники.Принадлежность
|ИЗ
| РегистрСведений.СоставБригады.СрезПоследних КАК СоставБригадыСрезПоследних
|ГДЕ
| СоставБригадыСрезПоследних.Сотрудники.Принадлежность = &Принадлежность
|
|УПОРЯДОЧИТЬ ПО
| Бригада УБЫВ";
Запрос.УстановитьПараметр("Принадлежность", Элементыформы.Принадлежность.Значение);


РезультатЗапроса = Запрос.Выполнить();

Выборка = РезультатЗапроса.Выбрать();
Бригада ="";
Пока Выборка.Следующий() Цикл
// Вставить обработку выборки ВыборкаДетальныеЗаписи
Если Бригада <> Выборка.Бригада Тогда
Бригада=Выборка.Бригада ;
новаяСтр = ВсеФизЛица.Добавить();
новаяСтр.ФизЛицо = Бригада;
КонецЕсли; 
новаяСтр = ВсеФизЛица.Добавить();
новаяСтр.ФизЛицо = Выборка.ФизЛицо;


КонецЦикла;
КонецЕсли;

Yandex
Возможно, вас также заинтересует
Реклама на портале
DJ_Serega
17.06.2014 12:16Ответ № 1

А общий признак есть в тех общих строках?

Bell
17.06.2014 12:33Ответ № 2

Если "Принадлежность" это признак, тогда результат запроса выгрузи в ТЗ -  Сверни- СвернутаяТЗ.Колчество()-1. .Зачем перегрузать запрос подсчетом строк.

Krolik13
17.06.2014 12:42Ответ № 3

Да есть общий признак  "Справочники.подразделения" (Бригада 5, Бригада 4 и т.д.) .

Поле после запроса принимает вот такой вид (скриншот). нужно что бы строки подсчитывались без  "Бригад" и прочих подразделений.

Krolik13
17.06.2014 13:07Ответ № 4

Все получилось, спасибо большое Bell и DJ_Serega. Свернул и посчитал. Вопрос на засыпку, подвал в табличном поле дает итого по "Число" , как отправить высчитанное количество строк в подвал по не числовой колонке ? 

DJ_Serega
17.06.2014 13:20Ответ № 5

Если не ошибаюсь то можно программно изменить текст подвала.

Krolik13
17.06.2014 13:26Ответ № 6

Каким методом это можно изобразить  ?

DJ_Serega
17.06.2014 14:17Ответ № 7

Попробуй через ЭлементыФормы достучаться.

Krolik13
17.06.2014 14:29Ответ № 8

Чего то не получается, можно закрывать тему. Спасибо.

kittybello
17.06.2014 16:03Ответ № 9

yj

Подсказка: Для редактирования своего ответа щелкните по значку (справа)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.