helpf.pro
Регистрация

v8: Фильтр в контекстном поиске номенклатуры

ElenaT
25.06.2014 11:46Прочитано: 781

Мне необходимо при контекстном поиске в поле Номенклатура ограничить список выбора. Как это сделать? Т. е. в справочнике номенклатура есть Товар1, Товар2, Товар3, а надо, чтобы в контексте высвечивался только Товар1. (Создан спец регистр доступа к товарам по контрагентам).

Yandex
Возможно, вас также заинтересует
Реклама на портале
DJ_Serega
25.06.2014 13:49Ответ № 1

В модуле менеджера справочника есть процедура <ОбработкаПолученияДанныхВыбора>.Можно ее использовать.

E_Migachev
25.06.2014 14:09Ответ № 2

Это в табличной части какого то документа? Посмотрите события поля,  там есть что-то связанное с выбором через контекст

ElenaT
25.06.2014 14:12Ответ № 3

Спасибо, нашла такую, попробую использовать. Жаль только, что придется конфигурацию трогать.

ElenaT
25.06.2014 14:14Ответ № 4

(2) нет, это надо для внешней обработки формирования заказа покупателя.

DJ_Serega
25.06.2014 16:15Ответ № 5

(3) ну можно играться с событиями элемента формы. Разница только в том, что в обработке это будет Только для обработки, а в менеджере будет более универсальной.

ElenaT
26.06.2014 18:11Ответ № 6

Все оказалось совсем просто. 

В форме обработки поля ввода "Номенклатура" прописываем событие "ОкончаниеВводаТекста"

Процедура ТоварыНоменклатураОкончаниеВводаТекста(Элемент, Текст, Значение, СтандартнаяОбработка)

СтандартнаяОбработка = Ложь;

НовыйСписок = Новый СписокЗначений;

Индекс = СписокВыбора.Количество();                        //СписокВыбора - это некий ранее определенный список значений

Пока Индекс > 0 Цикл

Если Найти(ВРег(СписокВыбора[Индекс-1].Значение.Артикул), ВРег(Текст)) ИЛИ

Найти(ВРег(СписокВыбора[Индекс-1].Значение.Наименование), ВРег(Текст)) Тогда

НовыйСписок.Добавить(СписокВыбора[Индекс-1].Значение);

КонецЕсли;

Индекс = Индекс - 1;

КонецЦикла;

Значение = НовыйСписок;

КонецПроцедуры

DJ_Serega
26.06.2014 22:51Ответ № 7

А список выбора можно так написать?

Для Каждого ТекущийЭлемент Из СписокВыбора Цикл    КонецЦикла

ElenaT
27.06.2014 15:52Ответ № 8

(7). Можно, конечно, это я примерно смысл описала. Вообще сейчас через запрос переделываю, т.к. работа с преобразованием строки (Верхний/нижний регистр) - жуткий тормоз как и любые функции преобразования.

Подсказка: Щелникни по Имени пользователя напротив ответа, и тем самым покажешь, что сообщение адресовано ему.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.