helpf.pro
Регистрация

v8: Форматированный документ

Bell
07.07.2014 10:46Прочитано: 664

Здравствуйте. Переделал спр. заметки на форматированный документ. Возник вопрос Как ПриАктивизацииСтроки() просмотреть на форме списка содержание заметки.

1.Создал реквизит Содержание (форматированный документ). перенес его на форму. СожержаниеХЗ - ХранилищеЗначений.

В процедуре пишу, не реагирует

Если  ТекущийЭлемент.Имя = "Список" Тогда

СтрокаСписка = ТекущийЭлемент.ТекущаяСтрока; Если СтрокаСписка <> Неопределено Тогда  Содержание = ПолучитьНавигационнуюСсылку(СтрокаСписка.Ссылка, "СодержаниеХЗ"); КонецЕсли; КонецЕсли;

Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
08.07.2014 22:03Ответ № 1

ты прям  списке хочешь посмотреть или в каком-то открываемом окне?

Bell
09.07.2014 09:55Ответ № 2

Прамо на форме списка. Как картинки.

Mokey
09.07.2014 11:45Ответ № 3

А вот тут что прописано?

ПолучитьНавигационнуюСсылку(СтрокаСписка.Ссылка, "СодержаниеХЗ")

Bell
09.07.2014 16:58Ответ № 4
Код 1C v 8.3
 &НаСервереПроцедура АктизвизироватьСтроку()		Если  ТекущийЭлемент.Имя = "Список" Тогда 				СтрокаСписка = ТекущийЭлемент.ТекущаяСтрока; 		Если СтрокаСписка <> Неопределено Тогда 			Содержание = СтрокаСписка.СодержаниеХЗ.Получить();		КонецЕсли;			КонецЕсли; сКонецПроцедуры    
Bell
09.07.2014 17:01Ответ № 5

Админу, что то не могу выделить код 1с. На моей стороне показывает что все нормально, когда отправляю сбит порядок.....Стоит ОПЕРА ПОСЛЕДНЯЯ

Mokey
10.07.2014 10:00Ответ № 6

http://infostart.ru/public/74958/

вот тут немного описано, как с этим зверем работать

Подсказка: Для выделения Кода используйте (в редакторе).
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.