helpf.pro
Регистрация

v8: Как при подключении по com соединению из 7.7 к 8.2 передать в запрос дату

satord
15.07.2014 16:07Прочитано: 1085
Как при подключении по com соединению из 7.7 к 8.2 передать в запрос дату?
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
15.07.2014 16:24Ответ № 1

покажи весь код подключения и запрос - подскажем

E_Migachev
15.07.2014 21:12Ответ № 2
Код 1C v 8.х
 Функция ТипаПереносОстатков()
Попытка
ОткрытиеБазы("V81.ComConnector");
Исключение
Сообщить("Не удалось открыть базу с заданными параметрами");
Возврат "";
КонецПопытки;
Стр="";
Если ВвестиСтроку(Стр,"Справочник",50)=1 Тогда
Спр=connection.Справочники.Справочник1.НайтиПоНаименованию(Стр);
Если Спр.Ссылка=connection.Справочники.Справочник1.ПустаяСсылка() Тогда
Спр=connection.Справочники.Справочник1.СоздатьЭлемент();
Спр.Наименование=Стр;
Спр.Записать();
КонецЕсли;
Док=connection.Документы.Документ1.СоздатьДокумент();
Док.Дата=connection.ЗначениеИзСтрокиВнутр("{""D"",20081231235959}");
Док.Реквизит1=Спр.Ссылка;
Док.Записать();
Движение=Док.Движения.РегистрНакопления1.ДобавитьПриход();
Движение.Период=connection.ЗначениеИзСтрокиВнутр("{""D"",20081231235959}");
Движение.Измерение1=Спр.Ссылка;
Движение.Ресурс1=15;
Док.Движения.РегистрНакопления1.Записать();
Сообщить(connection.String(Док.Ссылка));
КонецЕсли;
connection = "";
cntr = "";
КонецФункции
satord
16.07.2014 15:49Ответ № 3

При передаче даты окончания периода выборки в запрос в v8(com соединение) дата содержит время 0:0:0 и в принципе при добавлении одного дня запрос отрабатывает.Но при этом документ не должен иметь время 0:0:0.Попытка получить значение ТекДатаОкончания=v8.КонецДня(ДатаОкончания); выдает сообщение: Поле агрегатного объекта не обнаружено.

Заранее спасибо.

E_Migachev
16.07.2014 17:56Ответ № 4

попробуйте .ЗначениеИзСтрокиВнутр("{""D"",20081231235959}")

satord
17.07.2014 08:44Ответ № 5

Пробовал преобразования такого рода:

МДатаОкончания=v8.ЗначениеИзСтрокиВнутр("{""D"",20140601235959}");

МДатаОкончанияМ= v8.ЗначениеВСтрокуВнутр(МДатаОкончания);

В отладчике значение переменной :

МДатаОкончанияМ = "{"D",20140601000000}".

Видимо эти методы работают некорректно.Большое спасибо.Вопрос закрыт.

Подсказка: Вы можете добавить любую страничку в Избранное щелкнув по значку
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.