helpf.pro
Регистрация

v8.2 УП: ?Как через внешнюю обработку создать что либо в конфигурацию???

Kamil
26.08.2014 08:16Прочитано: 1556

Как через внешнюю обработку создать что либо в конфигурацию??? добавить код, создать справочник, документ и т.п. ???

Yandex
Возможно, вас также заинтересует
Реклама на портале
Kamil
26.08.2014 09:22Ответ № 1

В этом сайте есть хоть какая то подсказка??? Сайт работает???

E_Migachev
26.08.2014 11:34Ответ № 2

Kamil, обычным кодом создания справочника или документов.

Создание элементов справочника:

Код 1C v 8.3
 &НаКлиенте
Процедура ПоКнопкеНовыйКонтрагент(Команда)
       // Вставить содержимое обработчика.
        Перем НовыйКонтрагент;


        НовыйКонтрагент = Новый Структура("Наименование, ПолноеНаименование, ИНН");
        НовыйКонтрагент.Наименование = "РиК ООО";
        НовыйКонтрагент.ПолноеНаименование = "ООО Рога и копыта"; 
        НовыйКонтрагент.ИНН =  "123456789012";


 
        Если СоздатьНовогоКонтрагента(НовыйКонтрагент) = 0 Тогда
                Сообщить("Не удалось создать нового контрагента");
        КонецЕсли;


КонецПроцедуры
 


&НаСервере
Функция СоздатьНовогоКонтрагента(СтруктураСправочника)


        Перем НовыйКонтрагент,СпрПользователи;


        СпрКонтрагенты = Справочники.Контрагенты;
        НовыйКонтрагент = СпрКонтрагенты.СоздатьЭлемент();
        НовыйКонтрагент.Наименование = СтруктураСправочника.Наименование;
        НовыйКонтрагент.ПолноеНаименование = СтруктураСправочника.ПолноеНаименование; 
        НовыйКонтрагент.ИНН = СтруктураСправочника.ИНН;
        Попытка
                НовыйКонтрагент.Записать();
                Возврат 1;
        Исключение
                Возврат 0;
        КонецПопытки;


КонецФункции    

Документа

Код 1C v 8.3
 
&НаКлиенте
Процедура СоздатьНовыйДокумент(Команда)
   
        // Вставить содержимое обработчика.
        Если СоздатьНовыйДокументНаСервере() = 0 Тогда
                Сообщить("Не удалось создать новый документ");
        КонецЕсли;


КонецПроцедуры


&НаСервере
Функция СоздатьНовыйДокументНаСервере()
   
        Перем НоваяРасходнаяНакладная;
        Перем СтрокаТЧ;
   
        НоваяРасходнаяНакладная=ДокРасходнаяНакладная.СоздатьДокумент();
   
        //Заполняем реквизиты шапки
        НоваяРасходнаяНакладная.Дата=  ТекущаяДата();
        НоваяРасходнаяНакладная.Фирма =Справочники.Фирмы.ОсновнаяФирма;
        НоваяРасходнаяНакладная.Контрагент=Справочники.Контрагенты.НайтиПоКоду("000000001");
        НоваяРасходнаяНакладная.Склад=Справочники.Склады.ОсновнойСклад;
   
        //Заполняем табличную часть
        СтрокаТЧ=НоваяРасходнаяНакладная.ТЧТовары.Добавить();
        СтрокаТЧ.Товар=Справочники.Номенклатура.НайтиПоКоду("000000002");
        СтрокаТЧ.Цена=СтрокаТЧ.Товар.РозничнаяЦена;
        СтрокаТЧ.Количество= 2;
        СтрокаТЧ.Сумма=СтрокаТЧ.Цена*СтрокаТЧ.Количество;
   
        Попытка
                НоваяРасходнаяНакладная.Записать();
                Возврат 1;
        Исключение
                Возврат 0;
        КонецПопытки;
                                          
КонецФункции   


Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.