helpf.pro
Регистрация

v8: Изменение расписания регламентированного задания программно.

snfr1c
05.09.2014 12:32Прочитано: 2023

Здравствуйте!

релиз 1С.8.2.19.68

Необходимо программно изменить расписание регламентного задания. Столкнулся с непонятным поведением системы - во время исполнения кода вылетает.

вылетает во время установки значения ДетальныеРасписанияДня. подскажите что я делаю не так.

Код 1C v 8.х
 

Процедура ЗаписатьНажатие(Элемент)
ТекущееРегламентноеЗадание = НайтиРегламентноеЗаданиеПоНастройке(ЭлементыФормы.НастройкаВыполненияОбменаСсылка.Значение.РегламентноеЗадание);
ТекущееРегламентноеЗадание.Ключ = Ключ;
ТекущееРегламентноеЗадание.КоличествоПовторовПриАварийномЗавершении = 1;
ТекущееРегламентноеЗадание.ИнтервалПовтораПриАварийномЗавершении = 10;
СтруктураРасписания = ОбщегоНазначенияКлиентСервер.РасписаниеВСтруктуру(ТекущееРегламентноеЗадание.Расписание);
ВремяНачала = Дата("00010101073004");
СтруктураРасписания.ВремяНачала=ВремяНачала;
ДетальныеРасписанияДня = Новый Массив;
ДетальныеРасписанияДня.Добавить(СтруктураРасписания);
СтруктураРасписания.Вставить("ДетальныеРасписанияДня", ДетальныеРасписанияДня);
ТекущееРегламентноеЗадание.Расписание = ОбщегоНазначенияКлиентСервер.СтруктураВРасписание(СтруктураРасписания);
ТекущееРегламентноеЗадание.Записать();
КонецПроцедуры


Функция НайтиРеглЗаданиеПоПараметру(УникальныйНомерЗадания)

Попытка

Если НЕ ПустаяСтрока(УникальныйНомерЗадания) Тогда

УникальныйИдентификаторЗадания = Новый УникальныйИдентификатор(УникальныйНомерЗадания);
ТекущееРегламентноеЗадание = РегламентныеЗадания.НайтиПоУникальномуИдентификатору(УникальныйИдентификаторЗадания);

Иначе

ТекущееРегламентноеЗадание = Неопределено;

КонецЕсли;

Исключение

ТекущееРегламентноеЗадание = Неопределено;

    КонецПопытки;

Возврат ТекущееРегламентноеЗадание;

КонецФункции


Функция НайтиРегламентноеЗаданиеПоНастройке(РегламентноеЗадание) Экспорт

ТекущееРегламентноеЗадание = НайтиРеглЗаданиеПоПараметру(РегламентноеЗадание);

Возврат ТекущееРегламентноеЗадание;

КонецФункции
Yandex
Возможно, вас также заинтересует
Реклама на портале
snfr1c
08.09.2014 11:45Ответ № 1

Задачу решил. Вопрос закрываю.

Подсказка: Щелкнув по значку (справа от названия вопроса), вы получите список ответов на похожие вопросы!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.