helpf.pro
Регистрация

v8.3: Как выгрузить результат запроса в табличную часть на форме в 1С 8.3

kgn
04.11.2014 21:04Прочитано: 2063

В модуле формы пишу:

&НаСервереФункция Запрос1() Запрос = Новый Запрос; Запрос.Текст = "ВЫБРАТЬ .........

ТЗ = Запрос.Выполнить().Выгрузить(); ЗначениеВРеквизитФормы(ТЗ , "Объект.ТаблицаКВыгрузке");где ТаблицаКВыгрузке -это на форме ТабличнаяЧасть. Далее в другой процедуре Сформировать(..) пытаюсь пройти по ТаблицаКВыгрузке 

КонецФункции //---------------------------------- &НаКлиентеПроцедура Сформировать(Команда) ............

Для Каждого СтрокаТаблицаКВыгрузке Из Объект.ТаблицаКВыгрузке Цикл .....Поле1 =Объект.ТаблицаКВыгрузке.Сумма;      Поле2 = Объект.ТаблицаКВыгрузке.Сотрудник; ........ КонецЦикла

КонецПроцедуры 

В результате ТаблицаКВыгрузке пустая получилась.В Поле1 и Поле2 пусто.Подскажите,что не так ?

Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
05.11.2014 03:44Ответ № 1

такой код вообще не должен срабатывать...

с табличной частью ты можешь работать только на сервере, а что такое Поле 1 и 2?

kgn
06.11.2014 09:44Ответ № 2

Почему не должен сработать?Результат запроса получаю на сервере,затем выгружаю в таблицу на форме.И почему на клиенте я не могу использовать табличную часть на форме? А поле1..поле2..просто переменные условные.А какой есть другой вариант выгрузки результата запроса с сервера на клиент?

kgn
10.11.2014 19:05Ответ № 3
Вопрос закрыт!
Подсказка: Щелкнув по значку (справа от названия вопроса), вы получите список ответов на похожие вопросы!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.