helpf.pro
Регистрация

v8: Кто может помочь c OLE?

novichok20
13.01.2015 06:58Прочитано: 1035

ПутьКБазе = путьКБД1с7;

Если НЕ ЗначениеЗаполнено(ПутьКБазе)Тогда

Режим = РежимДиалогаВопрос.ОК;

Ответ = Вопрос("Не указан каталог" , Режим, 0);

Если Ответ = КодВозвратаДиалога.ОК Тогда

Возврат;

КонецЕсли;

КонецЕсли;

Пользователь = "пользователь";//пользователь базы 7.7

Пароль = "1";

МонопольныйРежимOLE = ""; // " /m";

ЗапускБезЗаставки = 1;

База = Новый COMОбъект("V1CEnterprise.Application");

СтрокаПодключения = "/D"""+СокрЛП(ПутьКБазе)+""" /N"""+СокрЛП(Пользователь)+""" /P"""+СокрЛП(Пароль)+"""";

РезультатПодключения = База.Initialize(База.RMTrade,СтрокаПодключения,?(ЗапускБезЗаставки = 1,"NO_SPLASH_SHOW",""));

Если НЕ РезультатПодключения Тогда

Сообщить("Не удалось произвести подключение к информационной базе");

КонецЕсли;

ТЗ = Новый ТаблицаЗначений;

ТЗ.Колонки.Добавить("Дата",,"ДатаД");

ТЗ.Колонки.Добавить("Представление", Новый ОписаниеТипов("СправочникСсылка.ВидыСпектаклей"),"Представление");

ТЗ.Колонки.Добавить("Продавец",Новый ОписаниеТипов("СправочникСсылка.ВидыНоменклатуры"),"Продавец");

ТЗ.Колонки.Добавить("билет",Новый ОписаниеТипов("СправочникСсылка.ВидыБСО"),"билет");

ТЗ.Колонки.Добавить("кол",Новый ОписаниеТипов("Число"),"кол");

ТЗ.Колонки.Добавить("сум",Новый ОписаниеТипов("Число"),"сум");

ДокТам =База.CreateObject("Документ.Продажа");

ДокТам.ВыбратьДокументы(ДатаНачала,ДатаКонца);

пока ДокТам.ПолучитьДокумент() = 1 цикл

ДокТам.ВыбратьСтроки();

пока ДокТам.получитьстроку() = 1 цикл

Стр = ТЗ.Добавить();

Стр.Представление = ДокТам.Концерт.Наименование;

//Стр.ДатаД =Н;

//ТЗ.ДатаД = ДокТам.ДатаДок;

//////представление

СпрСпект = База.CreateObject("Справочники.ВидыСпектаклей");

СпрСпект.ВыбратьЭлементы();

//Сообщить("_1_"+ДокТам.Концерт.ID);

Если НЕ ЗначениеЗаполнено(ДокТам.Концерт.ИД) = 1 тогда

Сообщить("Мероприятие с ID "+СокрЛП(ДокТам.Концерт.ИД)+" не найденно");

иначе

Если СпрСпект.НайтиПоКоду(ДокТам.Концерт.ИД) = 1 тогда

ТЗ.Представление =СпрСпект.ТекущийЭлемент();

иначе

Сообщить("Мероприятие с ID "+ДокТам.Концерт.ИД+" не найденно");

Конецесли;

Конецесли;

Выдает ошибку на СпрСпект = База.CreateObject("Справочники.ВидыСпектаклей")?

Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
13.01.2015 07:59Ответ № 1

Вроде пишется База.CreateObject("Справочник.ВидыСпектаклей")

novichok20
13.01.2015 08:53Ответ № 2

Исправил

представление и продавец в тз попадают 

но проблема я не знаю как вытянуть сумму и количество из тч

ТЗ = Новый ТаблицаЗначений;

ТЗ.Колонки.Добавить("Дата",Новый ОписаниеТипов("Строка"),"ДатаД");

ТЗ.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"),"Представление");

ТЗ.Колонки.Добавить("Продавец",Новый ОписаниеТипов("Строка"),"Продавец");

ТЗ.Колонки.Добавить("билет",Новый ОписаниеТипов("Строка"),"билет");

ТЗ.Колонки.Добавить("кол",Новый ОписаниеТипов("Число"),"кол");

ТЗ.Колонки.Добавить("сум",Новый ОписаниеТипов("Число"),"сум");

ДокТам =База.CreateObject("Документ.Продажа");

ДокТам.ВыбратьДокументы(ДатаНачала,ДатаКонца);

пока ДокТам.ПолучитьДокумент() = 1 цикл

ДокТам.ВыбратьСтроки();

Стр = ТЗ.Добавить();

Стр.Представление = ДокТам.Концерт.Наименование;

Стр.Продавец = ДокТам.МОЛотправитель.Наименование;

Стр.кол = "";

Стр.сум = "";

Конеццикла;

ЭлементыФормы.ТЗ.Значение = ТЗ;

ЭлементыФормы.ТЗ.СоздатьКолонки(); 

novichok20
13.01.2015 11:34Ответ № 3
Вопрос закрыт!
Подсказка: Вы можете добавить любую страничку в Избранное щелкнув по значку
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.