helpf.pro
Регистрация

v8.3: Проверка соединение с интернетом

silv
27.01.2015 11:49Прочитано: 1241

Скажите пожалуйста, как можно сделать проверку, наличия доступа в интернет.

Спасибо.

Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
27.01.2015 20:57Ответ № 1

Вот пример из типовой торговли:

Код 1C v 8.2 УП
 // инициализируем настройки прокси, если они определены 
НастройкиПрокси = ПолучитьНастройкиПрокси(); 
Если ЗначениеЗаполнено(НастройкиПрокси.ИмяПользователя) Тогда 
Прокси = Новый ИнтернетПрокси; 
Прокси.Пользователь = НастройкиПрокси.ИмяПользователя; 
Прокси.Пароль = НастройкиПрокси.Пароль; 
Иначе 
Прокси = Неопределено; 
КонецЕсли; 

// устанавливаем соединение с сервером 
Попытка 
Соединение = Новый HTTPСоединение(АдресСервераОнлайнПроверки, , , , Прокси); 
Исключение 
Сообщить("Не удалось установить соединение с сервером онлайн-проверки:" + Символы.ПС + ИнформацияОбОшибке().Описание, СтатусСообщения.Важное); 
Возврат Неопределено; 
КонецПопытки; 

еще варианты

Код 1C v 8.х
 Процедура Кнопка1Нажатие(Элемент)
перем ответ;
ответ =0;
ответ = ping("80.252.128.110");
Сообщить( ?(ответ >0 ,"Есть соединение","Нет соединения" ));
КонецПроцедуры

Function Ping(IPАдрес)
   objShell = Новый COMОбъект("WScript.Shell") ;
    objScriptExec = objShell.Exec("ping.exe -n 1 " + IPАдрес) ;
    strPingResults = НРег(objScriptExec.StdOut.ReadAll());
     Возврат   Найти(strPingResults, "ttl=");
EndFunction

или из стандартной загрузки банков

Код 1C v 8.х
 Процедура ПолучитьФайлРБК()
      
      СерверИсточник = "cbrates.rbc.ru";
      НТТР = Новый HTTPСоединение(СерверИсточник);
      
      Адрес = "bnk/bnk.exe";
      ВремКаталог = КаталогВременныхФайлов() + "tempBik";
      СоздатьКаталог(ВремКаталог);
      УдалитьФайлы(ВремКаталог,"*.*");
      Попытка
            НТТР.Получить(Адрес, ВремКаталог + "\" + мИмяФайлаЗип);
      Исключение
            Сообщить("Неудачная попытка соединения.");
            Возврат;
      КонецПопытки;
      
      Состояние("Выполняется обработка загрузки");
      
      КомандаСистемы(""""+ ВремКаталог + "\" + мИмяФайлаЗип + """", ВремКаталог);


      ФайлБИК = Новый Файл(ВремКаталог + "\" + мИмяФайлаБИК);
      ФайлРЕГ = Новый Файл(ВремКаталог + "\" + мИмяФайлаРег);
      
      НачальнаяДата = ТекущаяДата();
      Пока (НЕ (ФайлБИК.Существует() И ФайлРЕГ.Существует())) И ((ТекущаяДата() - НачальнаяДата) < 10) Цикл
      КонецЦикла;
      
      Если (ФайлБИК.Существует() И ФайлРЕГ.Существует()) Тогда
            ЗагрузитьКлассификаторСРБК(ВремКаталог);
            УдалитьФайлы(ВремКаталог,мИмяФайлаЗип);
            УдалитьФайлы(ВремКаталог,мИмяФайлаБИК);
            УдалитьФайлы(ВремКаталог,мИмяФайлаРег);
      КонецЕсли;
      
КонецПроцедуры // ПолучитьФайлРБК() 

7-рочный вариант через компоненту V7plus

Код 1C v 7.x
 Попытка
    Соединение = СоздатьОбъект("Addin.V7HttpReader");
    Соединение.КоличествоПопытокАвторизации = 3;
Исключение 
    Сообщить("Не удалось создать объект Addin.V7HttpReader!");
    Возврат 0;
КонецПопытки; 

Попытка
Соединение.ПолучитьКакСтроку("http://www.1c.ru/buhplace/lastnewstime.asp", Стр); 
Исключение
Сообщить("Либо нету инета... либо сайт 1С опять лежит!!!");
КонецПопытки;
silv
27.01.2015 22:25Ответ № 2

Спасибо, Вопрос закрыт. Спасибо.

Подсказка: Для быстрого поиска ответов - используйте 'Поиск'
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.