helpf.pro
Регистрация

v7: Как из ТЗ создать Документ в 7.7

novichok20
27.01.2015 15:42Прочитано: 1605

Как из ТЗ создать Документ в 7.7

Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
27.01.2015 21:02Ответ № 1

Примерно так:

Код 1C v 7.x
 Процедура ДокументСозданиеВ7рке() 
док = СоздатьОбъект("Документ.НачисленияУдержанияСписком"); 
док.Новый(); //Создаем новый документ

тз.ВыбратьСтроки(); // из ТЗ выбираем строки, в следующем цикле перебираем их создавая строки ТЧ документа
Пока тз.ПолучитьСтроку() = 1 Цикл 
док.НоваяСтрока(); 

док.Расчет = РасчетСтрокой; 
док.Сотрудник = тз.Сотрудник; 
док.НазначитьТип("Величина","Число","10.2"); // В документе Величина неопределенная 
Если док.Величина = "Сумма" Тогда 
док.Величина = тз.Итог; // Сумма из Тз в документ не попадает !! 
КонецЕсли; 

КонецЦикла; 
док.Записать(); 
док.Провести(); 
КонецПроцедуры // ДокументСозданиеВ7рке
novichok20
28.01.2015 08:04Ответ № 2

спасибо)

novichok20
28.01.2015 13:38Ответ № 3

как правильно открыть документ 7-ки из 8?

ДокТам =База.CreateObject("Документ.Материалы_поступление");

ДокТам.новый();

ДокТам.ДатаДок = ТзТемп.ДатаД;

ДокТам.НомерДок = ТзТемп.Номер;  ???

E_Migachev
28.01.2015 16:44Ответ № 4

всмысле открыть?

novichok20
28.01.2015 19:27Ответ № 5

в 8 гружу документы в ТЗ. затем через OLE подключаюсь к 7 и там создаю документы из своей ТЗ

novichok20
16.02.2015 08:03Ответ № 6
Вопрос закрыт!
Подсказка: Вы можете добавить любую страничку в Избранное щелкнув по значку
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.