helpf.pro
Регистрация

v8.2 УП: Все добрый день.Как отключить проверку контрагентов в декларации по НДС в Бухга

arbuz_anton
14.04.2015 17:47Прочитано: 3919
Yandex
Возможно, вас также заинтересует
Реклама на портале
arbuz_anton
14.04.2015 17:48Ответ № 1

Всем добрый день. Как отключить проверку контрагентов в декларации по НДС в Бухгалтерии 2.0.64.18. В бух 3.0 отключается а в Бух 2.0 найти так и не смог

E_Migachev
14.04.2015 19:18Ответ № 2

Если это та проверка инн и кпп с базой ФНС, то вроде как не отключается, но можно в коде закомментировать ее

arbuz_anton
14.04.2015 22:23Ответ № 3

Оказалась что это не та проверка. Там есть другая проверка на длину ИНН. 

Код 1C v 8.х
       Для Каждого СведенияОПродавце Из СтрокаДанных.СвПрод Цикл
УказаныСведенияОПродавце = Истина;

Если СведенияОПродавце.Свойство("ИННФЛ") Тогда
Если СтрДлина(СокрЛП(СведенияОПродавце.ИННФЛ)) <> 12 Тогда
СведенияОПродавцеНекорректны = Истина;
КонецЕсли;
Иначе
Если СтрДлина(СокрЛП(СведенияОПродавце.ИННЮЛ)) <> 10
ИЛИ СтрДлина(СокрЛП(СведенияОПродавце.КПП)) <> 9 Тогда
СведенияОПродавцеНекорректны = Истина;
КонецЕсли;
КонецЕсли;
КонецЦикла;

Почему то некоторые клиенту у нас в выгрузке воспринимаются как ФизЛица. Хотя при этом в самом контрагенте стоит Юр. лицо. Закономерности ни какой не увидел. Вариантов уже ни каких нет.

E_Migachev
15.04.2015 01:09Ответ № 4

так значит проверка инн не проходит?

arbuz_anton
15.04.2015 08:52Ответ № 5

Да. Именно в этом куске кода 

Код 1C v 8.х
 		Если СведенияОПродавце.Свойство("ИННФЛ") Тогда
Если СтрДлина(СокрЛП(СведенияОПродавце.ИННФЛ)) <> 12 Тогда
СведенияОПродавцеНекорректны = Истина;
КонецЕсли;
Иначе

При этом контрагент у меня Юр. лицо а программа его распознала как Физ. лицо.

arbuz_anton
15.04.2015 10:19Ответ № 6

Вопрос закрыт. обновились до 2.0.64.20 и после этого сформировали новую декларацию по НДС и ошибок не стало.

Подсказка: Щелкнув по значку (справа от названия вопроса), вы получите список ответов на похожие вопросы!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.