helpf.pro
Регистрация

v8.2 УП: Долгое отображение картинки на форме внешней обработки

ghostrid3r
28.05.2015 14:48Прочитано: 1086

Добрый день уважаемые. Подскажите как можно решить проблему долгой подгрузки картинок при переключении  строк в табличной части обработки, при том, что картинку для отдельной строки мы выбираем и храним в обработке до записи. Может можно как то кешировать картинки, или обращатся к картинке по пути, не помещая по временное хранилище, другого способа показать при открытии картинки я не знаю. Подскажите куда смотреть? 

Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
29.05.2015 02:48Ответ № 1

покажи код, как ты выводишь, меняешь картинки

ghostrid3r
29.05.2015 12:12Ответ № 2
Код 1C v 8.2 УП
 &НаКлиенте
Процедура АдресКартинкиНажатие(Элемент, СтандартнаяОбработка)

СтандартнаяОбработка = Ложь;
Элементы.АдресКартинки.РазмерКартинки = РазмерКартинки.Пропорционально;

ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
ДиалогОткрытияФайла.Заголовок = "Выберите файл с изображением";
ДиалогОткрытияФайла.ПолноеИмяФайла = "";
ДиалогОткрытияФайла.ПредварительныйПросмотр = Истина;
ДиалогОткрытияФайла.Фильтр = "*.*";
Если НЕ ДиалогОткрытияФайла.Выбрать() Тогда
Возврат;
КонецЕсли;       
ПолноеИмяФайла = ДиалогОткрытияФайла.ПолноеИмяФайла;
ПоказатьКартинку(ПолноеИмяФайла);
ТекущиеДанные = Элементы.Товары.ТекущиеДанные;
Если НЕ ТекущиеДанные = Неопределено Тогда
УстановитьПараметрыСтроки(ТекущиеДанные);
КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура ПоказатьКартинку(ПолноеИмяФайла)
    АдресКартинки = ПоместитьВоВременноеХранилище(Новый Картинка(ПолноеИмяФайла), УникальныйИдентификатор);
Элементы.АдресКартинки.Обновить();
КонецПроцедуры


&НаКлиенте
Процедура ТоварыПриАктивизацииСтроки(Элемент)

ТекущаяСтрока = Элементы.Товары.ТекущиеДанные;
Если Объект.Товары.Количество() Тогда

АдресКартинки = ТекущаяСтрока.ссылкаДляКартинки;

КонецЕсли;
УстановитьДоступностьСвойств();

КонецПроцедуры

&НаКлиенте
Процедура УстановитьПараметрыСтроки(СтрокаТовара)
СтрокаТовара.СсылкаДляКартинки         = АдресКартинки;
КонецПроцедуры





all4cf
29.05.2015 19:37Ответ № 3

а сетевое подключение стабильное? может задержки сети?

ghostrid3r
29.05.2015 19:51Ответ № 4

да стабильное, просто фото маленьких размеров быстро подгружаются, а фото больших размеров с задержками что напрягает.

Подсказка: Вы можете приложить к ответу файл или изображение щелкнув по значку или в редакторе.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.