helpf.pro
Регистрация

v8.2 УП: Стандартная процедура печати

Lavr
11.06.2015 08:36Прочитано: 1544

Здравствуйте, есть справочник Инвентаризация (список оборудования с инв. номерами, ценами и тд.) с реквизитами, после формирования стандартной процедуры печати каждая запись выводится отдельно с заголовком. Подскажите пожалуйста способ вывода на печать в виде таблицы?

&НаКлиентеПроцедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды) //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать) ТабДок = Новый ТабличныйДокумент; Печать(ТабДок, ПараметрКоманды);

ТабДок.ОтображатьСетку = Ложь; ТабДок.Защита = Ложь; ТабДок.ТолькоПросмотр = Ложь; ТабДок.ОтображатьЗаголовки = Ложь; ТабДок.Показать(); //}}КонецПроцедуры

&НаСервереПроцедура Печать(ТабДок, ПараметрКоманды) Справочники.Инвентаризация.Печать(ТабДок, ПараметрКоманды);КонецПроцедуры

Yandex
Возможно, вас также заинтересует
Реклама на портале
Lavr
11.06.2015 09:23Ответ № 1

Процедура Печать(ТабДок, Ссылка) Экспорт //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать) Макет = Справочники.Инвентаризация.ПолучитьМакет("Печать"); Запрос = Новый Запрос; Запрос.Текст = "ВЫБРАТЬ | Инвентаризация.Амортизация, | Инвентаризация.БалансоваяСтоимость, | Инвентаризация.ДатаПриобретения, | Инвентаризация.ИнвентарныйНомер, | Инвентаризация.МатериальноеЛицо, | Инвентаризация.НаименованиеОС, | Инвентаризация.НаименованиеФилиала, | Инвентаризация.ПодразделениеФилиала, | Инвентаризация.Стоимость |ИЗ | Справочник.Инвентаризация КАК Инвентаризация |ГДЕ | Инвентаризация.Ссылка В (&Ссылка)"; Запрос.Параметры.Вставить("Ссылка", Ссылка); Выборка = Запрос.Выполнить().Выбрать();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок"); Шапка = Макет.ПолучитьОбласть("Шапка"); ТабДок.Очистить();

ВставлятьРазделительСтраниц = Ложь; Пока Выборка.Следующий() Цикл Если ВставлятьРазделительСтраниц Тогда ТабДок.ВывестиГоризонтальныйРазделительСтраниц(); КонецЕсли;

ТабДок.Вывести(ОбластьЗаголовок);

Шапка.Параметры.Заполнить(Выборка); ТабДок.Вывести(Шапка, Выборка.Уровень());

ВставлятьРазделительСтраниц = Истина; КонецЦикла; //}}КонецПроцедуры

IBReiter
11.06.2015 09:58Ответ № 2

У Вас на каждом витке цикла выполняется 

Код 1C v 8.2 УП
 ТабДок.Вывести(ОбластьЗаголовок);   

Может в этом дело?

Lavr
11.06.2015 11:04Ответ № 3

Благодарю за помощь, сделал так:

Процедура Печать(ТабДок, Ссылка) Экспорт //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать) Макет = Справочники.Инвентаризация.ПолучитьМакет("Печать"); Запрос = Новый Запрос; Запрос.Текст = "ВЫБРАТЬ | Инвентаризация.Амортизация, | Инвентаризация.БалансоваяСтоимость, | Инвентаризация.ДатаПриобретения, | Инвентаризация.ИнвентарныйНомер, | Инвентаризация.МатериальноеЛицо, | Инвентаризация.НаименованиеОС, | Инвентаризация.НаименованиеФилиала, | Инвентаризация.ПодразделениеФилиала, | Инвентаризация.Стоимость |ИЗ | Справочник.Инвентаризация КАК Инвентаризация |ГДЕ | Инвентаризация.Ссылка В (&Ссылка)"; Запрос.Параметры.Вставить("Ссылка", Ссылка); Выборка = Запрос.Выполнить().Выбрать();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок"); ОбластьШапка = Макет.ПолучитьОбласть("Шапка"); Шапка = Макет.ПолучитьОбласть("Таблица"); ТабДок.Очистить(); ТабДок.Вывести(ОбластьЗаголовок); ТабДок.Вывести(ОбластьШапка); ВставлятьРазделительСтраниц = Ложь; Пока Выборка.Следующий() Цикл

Шапка.Параметры.Заполнить(Выборка); ТабДок.Вывести(Шапка, Выборка.Уровень());

КонецЦикла; //}}КонецПроцедуры

Подсказка: Для выделения Кода используйте (в редакторе).
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.