helpf.pro
Регистрация

v8: обновление УФ

ulka5659
25.09.2015 08:54Прочитано: 851

Доброго дня. Подскажите пожалуйста... Как обновить данные на форме.

Есть форма ввожу изменения в динамический список, провожу данные остаются прежними в ДеревеЗначений, которое по сути дублирует список надо просто обновить, при переоткрытии обновляется.

Пробую так:

Код 1C v 8.3
 &НаКлиентеПроцедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)   Если имяСобытия = "Обновить"      Тогда    ЭтаФорма.Прочитать();      ЭтаФорма.ОбновитьОтображениеДанных();   КонецЕсли;КонецПроцедуры   
Код 1C v 8.3
 &НаКлиентеПроцедураПослеЗаписи(ПараметрыЗаписи)   Оповестить("Обновить");КонецПроцедуры   
Код 1C v 8.3
 но ничего, где ошиблась?   
Yandex
Возможно, вас также заинтересует
Реклама на портале
IBReiter
25.09.2015 11:19Ответ № 1

Не пишите, когда находитесь в контексте формы, "ЭтаФорма". Методы итак доступны

Основная таблица и динамическое считывание данных указаны?

IBReiter
25.09.2015 11:23Ответ № 2

Проверьте еще так: Элементы.ДеревоЗначений.Обновить()

ulka5659
25.09.2015 11:27Ответ № 3

простите за дремучесть, но я спрошу: "Основная таблица и динамическое считывание данных указаны?" это свойства для формы указать? Я не указывала просто. Где посмотреть?

ulka5659
25.09.2015 11:36Ответ № 4

Не будет у меня это работать таким способом. Потому как я изначально, чтобы получить дерево запросом выгружаю его и получаю нужный вид. Теперь мне надо просто запустить этот запрос снова, чтоб выгрузить по новой данные в виде дерева, а не обновлять т.к. обновлять нечего по сути.))))

ulka5659
25.09.2015 11:38Ответ № 5

Или выгрузить данные заново, только где в какой процедуре (событии) на сервере?

ulka5659
25.09.2015 11:41Ответ № 6

обновить доступно на "клиенте" , там ЗначениеВРеквизитФормы использовать нельзя - это сервер ....как?

IBReiter
25.09.2015 11:42Ответ № 7

Вот эту процедуру, где вы запросом дерево собираете и получаете нужный вид, вам нужно вызвать в обработке оповещения

ulka5659
25.09.2015 11:58Ответ № 8

Вооооот. Спасибо!!! Только теперь надо еще чтоб в развернутом виде было

Код 1C v 8.3
 &НаКлиенте
Процедура ПослеЗаписи(ПараметрыЗаписи)
ПоказатьПраваДоступКИБНаСервере();
Для Каждого Строка ИЗ ДЗ_Подр.ПолучитьЭлементы() Цикл
Элементы.ТЧИмеющиесяПраваТест.развернуть(Строка.ПолучитьИдентификатор(), Истина);
КонецЦикла;
КонецПроцедуры


ulka5659
25.09.2015 11:59Ответ № 9

Ну да это мелочи)

ulka5659
25.09.2015 12:00Ответ № 10

Что-то обработкаОповещения у меня не работала....

ulka5659
25.09.2015 12:13Ответ № 11
Вопрос закрыт!
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.