helpf.pro
Регистрация

Подстановка печати фирмы в документ при печати.

SeReGa
22.01.2010 14:08Прочитано: 1544
Подстановка печати фирмы в документ при печати.

Добрый день!

Суть такая: допустим у меня есть несколько фирм. У этих фирм в их карточке выбрана печать(как картинка):
Файлfoto=КаталогИБ()+"р"+сокрлп(код)+".jpg";
Если ФС.СуществуетФайл(Файлfoto)=1 Тогда
foto.Загрузить(Файлfoto);
КонецЕсли;
Вопрос: как сделать так, чтобы при печати документа(к примеру, печать счета) туда вставлялась печать конкретной фирмы из документа?
Yandex
Возможно, вас также заинтересует
Реклама на портале
E_Migachev
22.01.2010 15:07Ответ № 1
Привет!
На примере счета: В печатную форму счета из которой будешь печатать добавляется объект "рисунок", в его тексте:
Код 1C v 7.x
 Рисунок(ТаблицаПечати.ТекущийОбъект)

И в модуле обработки функция:
Код 1C v 7.x
 Функция Рисунок (Куда) Экспорт
ПолноеИмяФото = КаталогИБ()+"р"+сокрлп(код)+".jpg";
ФайлФото=ФС.НайтиПервыйФайл(ПолноеИмяФото);
Найден=?(ПустаяСтрока(ФайлФото)=0,1,0);
Если Найден = 1 Тогда
Куда.Загрузить(Каталог+ФайлФото);
Куда.РежимРисования(3);
КонецЕсли;
КонецФункции
SeReGa
22.01.2010 15:14Ответ № 2
Спасибо. Сейчас попробую.
E_Migachev
22.01.2010 16:18Ответ № 3
Пожалуйста, размести потом тут свой варинат кода.
E_Migachev
19.03.2010 08:44Ответ № 4
Закрытие темы!
Подсказка: Вы получили ответ на свой вопрос - закройте вопрос!
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.