helpf.pro
Регистрация

v8: Работа с макетом

Ermak
07.10.2015 09:52Прочитано: 1064

Подскажите как можно с макета перейти сразу в Справочник.ЛицевыеСчетаАбонентов

Вот код макета

Код 1C v 8.х
 Процедура ОсновныеДействияФормыОсновныеДействияФормыВыполнить(Кнопка)
    ТабДок = Новый ТабличныйДокумент;
    Макет=ПолучитьМакет("Макет");
    ОбластьМакета=Макет.ПолучитьОбласть("Шапка");
    Областьмакета.Параметры.НазваниеТемы="Список льготников по" + " " + Регион;
    ТабДок.Вывести(ОбластьМакета);
    ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
    ТабДок.Вывести(ОбластьМакета);
   
    Запрос = Новый Запрос;
    ТекстЗапроса =
    "ВЫБРАТЬ
    |   ЛицевыеСчетаАбонентовЛьготники.Ссылка,
    |   ЛицевыеСчетаАбонентовЛьготники.Льгота,
    |   ЛицевыеСчетаАбонентов.Регион,
    |   ЛицевыеСчетаАбонентовЛьготники.ФИО.Наименование КАК ИмяЛьготник,
    |   ЛицевыеСчетаАбонентовЛьготники.ФИО.ДатаРождения КАК РожденияЛьготник,
    |   ЛицевыеСчетаАбонентов.Наименование КАК Адрес,
    |   ЛицевыеСчетаАбонентов.Код
    |ИЗ
    |   Справочник.ЛицевыеСчетаАбонентов.Льготники КАК ЛицевыеСчетаАбонентовЛьготники
    |       ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ЛицевыеСчетаАбонентов КАК ЛицевыеСчетаАбонентов
    |       ПО ЛицевыеСчетаАбонентовЛьготники.Ссылка = ЛицевыеСчетаАбонентов.Ссылка";
   
    Если ЗначениеЗаполнено(Регион) Тогда
        ТекстЗапроса=ТекстЗапроса+"
        |ГДЕ
        |   ЛицевыеСчетаАбонентов.Регион=&Регион";
        Запрос.УстановитьПараметр("Регион",Регион);
    КонецЕсли; 
    Запрос.Текст=ТекстЗапроса;
    Результат = Запрос.Выполнить().Выбрать();
    Номер = 0;
    Пока Результат.Следующий() Цикл
        Номер = Номер + 1;
        Областьмакета=Макет.ПолучитьОбласть("Строка");
        ОбластьМакета.Параметры.Номер = Номер;
        ОбластьМакета.Параметры.ЛС = Результат.Код;
        ОбластьМакета.Параметры.ФИО = Результат.ИмяЛьготник;
        ОбластьМакета.Параметры.Дата = Формат(Результат.РожденияЛьготник,"ДЛФ=Д");
        ОбластьМакета.Параметры.Адрес = Результат.Адрес;
        ОбластьМакета.Параметры.КодЛьгот = Результат.Льгота.Код;
        ТабДок.Вывести(ОбластьМакета);
        Состояние("Количество льготников =" + " " + Номер);
    КонецЦикла;
    ТабДок.ОриентацияСтраницы=ОриентацияСтраницы.Портрет;
    ТабДок.АвтоМасштаб=Истина;
    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.Защита = Ложь;
    ТабДок.ТолькоПросмотр = Истина;
    ТабДок.ОтображатьЗаголовки = Ложь;
    ТабДок.ПовторятьПриПечатиСтроки=ТабДок.Область("R4:R5");  
    ТабДок.Показать();
   
КонецПроцедуры
Yandex
Возможно, вас также заинтересует
Реклама на портале
Ermak
07.10.2015 11:20Ответ № 1
Вопрос закрыт!
EMigachev
07.10.2015 14:19Ответ № 2

Через параметр расшифровки

Подсказка: Для выделения Кода используйте (в редакторе).
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.