helpf.pro
Регистрация

v8. Выгрузить табличную часть документа в таблицу значений

snfr1c
02.11.2010 15:09Прочитано: 21388
Здравствуйте!
Помогите новичку. Подскажите, пожалуйста, как выгрузить табличную часть документа в таблицу значений.
в 7.7 всё просто ВыгрузитьТабличнуюЧасть(ТЗ), а в v8.1 не нашел пока аналога. *11
Yandex
Возможно, вас также заинтересует
Реклама на портале
snfr1c
02.11.2010 15:17Ответ № 1
пока писал вопрос, параллельно нашел кучу вариантов ответа:
ВремТаблицаЗнач=Новый ТаблицаЗначений;
ВремТаблицаЗнач.Колонки.Добавить("Номенклатура");
ДокВыборка = Документы.РеализацияТоваровУслуг.Выбрать(ДатаНач,ДатаКон);
ЭлементыФормы.ТаблицаЗнач.Значение=ДокВыборка.Товары.Выгрузить();
ЭлементыФормы.ТаблицаЗнач.СоздатьКолонки();
КонецЦикла;
//вариант
Процедура КнопкаВыполнитьНажатие(Кнопка)
ВремТаблицаЗнач=Новый ТаблицаЗначений;
ВремТаблицаЗнач.Колонки.Добавить("Номенклатура");
ВремТаблицаЗнач.Колонки.Добавить("НомерГТД");
ВремТаблицаЗнач.Колонки.Добавить("Дата");
ВремТаблицаЗнач.Колонки.Добавить("Сумма");
ВремТаблицаЗнач.Колонки.Добавить("СуммаНДС");
ВремТаблицаЗнач.Колонки.Добавить("Количество");
ДокВыборка = Документы.РеализацияТоваровУслуг.Выбрать(ДатаНач,ДатаКон);
Пока ДокВыборка.Следующий() Цикл
Для Каждого СтрокаТоваров Из ДокВыборка.Товары Цикл
Стр=ВремТаблицаЗнач.Добавить();
Стр.НомерГТД = СтрокаТоваров.Номенклатура.Ссылка;
Стр.Номенклатура = СтрокаТоваров.Номенклатура.Ссылка;
КонецЦикла;
КонецЦикла;
ЭлементыФормы.ТаблицаЗнач.Значение=ВремТаблицаЗнач;
ЭлементыФормы.ТаблицаЗнач.СоздатьКолонки();
КонецПроцедуры
E_Migachev
02.11.2010 15:21Ответ № 2
(0)
Код 1C v 8.х
 ТаблЗнач = ДокТаблЧастьТовары.Выгрузить();    
E_Migachev
02.11.2010 15:25Ответ № 3
(1) Выделяй код, так удобнее )

Используй Выгрузить() как в (2) или в (1) в первом варианте! во втором, создание вручную ТЗ - это неверный вариант решения *09
snfr1c
02.11.2010 15:32Ответ № 4
хорошо.
Подсказка: Вы можете приложить к ответу файл или изображение щелкнув по значку или в редакторе.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.