helpf.pro
Регистрация

v8: Переход с Табличного поля

Ermak
26.10.2015 10:49Прочитано: 826

Я  выгружаю данные документов в табличное поле, подскажите как можно с табличного поля попасть в документ\

Код 1C v 8.х
 	Запрос = Новый Запрос;
ТекстЗапроса = "ВЫБРАТЬ
              | ЗаявкаЕдиноеОкно.Дата КАК Период,
              | ЗаявкаЕдиноеОкно.ЛицевойСчет,
              | ЗаявкаЕдиноеОкно.ТипЗаявки,
              | ЗаявкаЕдиноеОкно.Причина,
              | ЗаявкаЕдиноеОкно.Статус
              |ИЗ
              | Документ.ЗаявкаЕдиноеОкно КАК ЗаявкаЕдиноеОкно
              |ГДЕ
              | ЗаявкаЕдиноеОкно.ЛицевойСчет =ЛС";

Запрос.УстановитьПараметр("ЛС",ЛС);
Запрос.Текст=ТекстЗапроса;
Результат=Запрос.Выполнить();
ТаблицаИсторияЗ=Результат.Выгрузить();

Если ТаблицаИсторияЗ.Количество()>0 Тогда
ЭлементыФормы.ТаблицаИсторияЗ.СоздатьКолонки();
ЭлементыФормы.ТаблицаИсторияЗ.Колонки.Период.Ширина=20;
ЭлементыФормы.ТаблицаИсторияЗ.Колонки.ТипЗаявки.Ширина=20;
ЭлементыФормы.ТаблицаИсторияЗ.Колонки.Причина.Ширина=20;
ЭлементыФормы.ТаблицаИсторияЗ.Колонки.Статус.Ширина=20;
КонецЕсли;
Yandex
Возможно, вас также заинтересует
Реклама на портале
IBReiter
26.10.2015 12:21Ответ № 1

Что такое: табличное поле?

Что значит: попасть?

Где выполняется этот код?

Ermak
26.10.2015 14:43Ответ № 2

Выводит данные в табличное поле обработки

Код 1C v 8.х
 Процедура ПолучитьЗаявкиЕО(ЛС)
Запрос = Новый Запрос;
ТекстЗапроса = "ВЫБРАТЬ
              | ЗаявкаЕдиноеОкно.Дата КАК Период,
              | ЗаявкаЕдиноеОкно.ЛицевойСчет,
              | ЗаявкаЕдиноеОкно.ТипЗаявки,
              | ЗаявкаЕдиноеОкно.Причина,
              | ЗаявкаЕдиноеОкно.Статус
              |ИЗ
              | Документ.ЗаявкаЕдиноеОкно КАК ЗаявкаЕдиноеОкно
              |ГДЕ
              | ЗаявкаЕдиноеОкно.ЛицевойСчет =ЛС";

Запрос.УстановитьПараметр("ЛС",ЛС);
Запрос.Текст=ТекстЗапроса;
Результат=Запрос.Выполнить();
ТаблицаИсторияЗ=Результат.Выгрузить();

Если ТаблицаИсторияЗ.Количество()>0 Тогда
ЭлементыФормы.ТаблицаИсторияЗ.СоздатьКолонки();
ЭлементыФормы.ТаблицаИсторияЗ.Колонки.Период.Ширина=20;
ЭлементыФормы.ТаблицаИсторияЗ.Колонки.ТипЗаявки.Ширина=20;
ЭлементыФормы.ТаблицаИсторияЗ.Колонки.Причина.Ширина=20;
ЭлементыФормы.ТаблицаИсторияЗ.Колонки.Статус.Ширина=20;
КонецЕсли;

КонецПроцедуры

Это данные созданного документа ЗаявкаЕдиноеОкно, хотелось бы открыть документ который выводится

IBReiter
26.10.2015 16:55Ответ № 3

Ссылку еще в запросе нужно выбрать

Ermak
26.10.2015 17:10Ответ № 4

Спасибо

Ermak
26.10.2015 17:15Ответ № 5
Вопрос закрыт!
Подсказка: Для быстрого перемещения к последнему ответу или к вопросу используйте или .
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.